Subject: Re: Off tangent X question...
To: Arne Henrik Juul <>
From: [This is my bacque pas, this is my faux pas] <>
List: current-users
Date: 10/22/1997 23:23:59
[can someone please point me to a more relevant mailing list so I don't
annoy everyone with this garbage?]

Arne Henrik Juul sez:
 * does
 * 	xterm -fn '-*-cour*-m*-r-n*-12-*'
 * work?


 *  > To make it even more puzzling, I get NO error output when I start an
 *  > xterm from the command line.
 *  > 
 *  > In fact, NONE of my X properties as returned by 'xrdb' seem to be taking
 *  > effect.
 * sounds like it... at my machine, doing this:
 * frida:~:$ xrdb
 * XTerm*Font:     -*-cour*-m*-r-n*-12-*
 * frida:~:$ xterm
 * works as expected (xterm with default settings, white background
 * etc, but the right courier font).  Could you try that?

That works.

If I then re-read my .Xdefaults file, which has the line XTerm*Font
as described above, I still get font 'fixed' with no warnings.

I've tried with:

...and so on, mixing case as appropriate [with the appropriate font on
the other side of the property rule, of course...].

 * no... maybe your X resource database and/or ~/.Xdefaults are screwed
 * up somehow?  It might of course be a problem with the specific version
 * you used; I use my self-compiled X (6.3 pl2 on the sparc).  But I
 * doubt that others could miss seeing such a problem.

I'd _LOVE_ to hear from them.  Could someone PLEASE tell me what might be
going wrong?

Can't be mixed libs because I blew away the original installation before
I installed this one, just to be on the safe side.

If I specify fonts via -fn, there are no problems [I have the old
suntools serif16 and gallant19 fonts in bdf format if anyone wants
them -- I use gallant19 as the default font for failsafe sessions,
placing a 80x34 window right over the console space :-)].

 *   -  Arne H. J.

Friends don't let friends use System V.