Subject: Re: Installboot????
To: Andrew S. Clapp <>
From: David M. Stanhope <>
List: current-users
Date: 10/13/1997 12:29:30
> In my unawakened state, I also failed to mention that I
> put the drive in a different machine.  The new pentium 90
> motherboard will either complain about not finding the OS
> or haveing a read error.  As I understand from a friend, 
> there have been some changes in the hardware standard since
> the 486, in that the 586 now looks at the disk and tried to
> determine if there is a bootable OS.  I'm not sure how to
> turn this "feature" off.  Are there some phrases I can look
> for in the bois?  Do I need to re install the disk, or can
> I fix it?  It will boot wd0a via the install floppy. 
> (boot wd0a:/netbsd).  
> Another person suggested doing an "installboot biosboot.sym /dev/wd0c".
> What effect will that have?
> -ASC
> On Mon, 13 Oct 1997 11:10:26 +0200 (MET DST) 
>  Matthias Drochner <> wrote:
>  > Excerpts from netbsd: 13-Oct-97 Installboot???? "Andrew S. Clapp"@peak.o (485)
>  > 
>  > > I can boot wd0a:/netbsd via the floppy, but
>  > > My bios does not appear to see the OS on the drive
>  > > so I cannot boot directly to the hard drive.
>  > 
>  > Did you change something with the partitioning?
>  > What's the layout of the hard drive?
>  > What happens if you try to boot it?
>  > 
>  > > I tried to "installboot biosboot.sym /dev/rwd0a" and
>  > > "installboot -f biosboot.sym /dev/rwd0a" and neither
>  > > worked.
>  > 
>  > Did the "installboot" fail?
>  > Can you try "installboot -v biosboot.sym /dev/rwd0a"
>  > and tell what it says?
>  > 
>  > best regards
>  > Matthias
>  > 
> *                                                    *
>     Andrew S. Clapp - - WWW Support
> *                                                    *
I haven't got all of what went on here but have recently discovered that
new intel pentium boards (AN430 with Phoniex Bios) don't correctly pass
the boot drive to the boot-sector, the bios always sets the dl register to
0. This has the effect that the system boots and installs fine from the
floppy but when trying to boot from the hard-disk, the boot-sector gets
loaded from the hard-disk but then thinks it got loaded from the floppy and
tries to continue booting from the floppy, and since you don't have the boot
floppy in at this point, the boot-sector prints 'read error'. I hacked around
this by installing a custom boot-sector on the hard-disk which assumes
it got loaded from the hard-disk. The exact same hard-disk with a standard
boot-sector boots and runs fine on other intel pentium/pentium-pro/pentium-II
motherboards, which all seem to have AMI bios.
                       Dave Stanhope