Subject: today's -current can't be (easily) installed except on yesterday's?
To: None <current-users@NetBSD.ORG>
From: John F. Woods <>
List: current-users
Date: 10/11/1997 23:56:56
I tried to upgrade from July 13 sources to -current, and failed
miserably.  The short version of the tale of woe is:

(0) install headers, libraries, but no utilities (other than yacc
and config, built with the previous library set).  Build new kernel.

(1) new kernel crashed badly, "privileged instruction trap" at a
random address, during or after the link-editor cache load step.
This, however, may have been caused by accidently trying to go
multi-user with the new kernel still named /nnetbsd.  (Gosh, I wish
that worked.)  Or maybe it failed because something is wrong, I don't
know (yet).

(2) booting the old kernel ALSO didn't work: having installed in addition to the original, old utilities
were now trying to make use of a brand-new system call (Bad release
engineer!  No pizza!), and thus were coredumping right and left during
startup.  Fortunately, I was able to log in and delete the offensive
shared library, but now my regular library is useless for doing static
links.  (I shudder to think what things would be like if I had gone
ahead and installed new utilities.)

I wonder if (a) we have gotten into a "you can't get there from here"
situation where the only way to get to -current is with a floppy boot
of the new kernel and an installation floppy set, and (b) if so, is
this understood to be the case and considered acceptable?  It's
awfully easy to create situations like that when you incrementally
upgrade and thus finesse discontinuities.

Or is the entire source of my problems that not booting "/netbsd"
ruined what would otherwise have been a perfectly happy combination
(old utilities, new libraries, new kernel)?

Thank goodness I have a spare root partition for just such an
emergency.  DESTDIR= to the rescue.  (Other sage advice: back up
early, back up often.)