Subject: Re: DEC 21x4x ethernet driver in 100baseTX mode
To: Matt Thomas <>
From: Andreas Wrede <>
List: current-users
Date: 10/03/1997 07:35:34
On Fri, 03 Oct 1997 05:32:19 EDT Matt Thomas writes
> At 11:07 PM 10/2/97 -0400, Andreas Wrede wrote:
> >
> >I also see these abnormal interrupt messages on a "de1: DEC 21040 [10Mb/s]
> >pass 2.3" in normal 10Mb mode.
> >
> >de1: abnormal interrupt: transmit underflow
> On what type of system? That messages means the tulip chip is incapable
> of dma'ing fast enough (1.25MB/s!) to keep the transmit FIFO not empty.
> Is there other PCI traffic or slow ISA cards?

The system is a Pentium 120 with 64Mb RAM, Adaptec 2940 SCSI, Matrox 
Millennium video adapter and 2 DEC 21040 based cards (One DEC and one SMC) 
on the PCI bus.  On the ISA bus it has the build in I/O ports, a second I/O 
card and a Soundblaster 16.

The cards that shows the de1: abnormal interrupt: transmit underflow is 
attached via 3Com hub to a network of about 10 devices. The message has 
occured about 25 times over the last 5 days, with no visible pattern.

The de0 card has not had a single transmit underflow in 5 days (thats when this 
machine went -current again).  It's attached via a LanCity cable modem to 
500Mb cable tv based network. It reports lots of bad crc errors which is 

Full boot messages below:

NetBSD 1.2G (WOFFI) #1: Sat Sep 27 15:52:35 EDT 1997
cpu0: family 5 model 2 step 5
cpu0: Intel Pentium (P54C) (586-class)
real mem  = 66715648
avail mem = 60346368
using 840 buffers containing 3440640 bytes of memory
mainbus0 (root)
pci0 at mainbus0 bus 0: configuration mode 1
pchb0 at pci0 dev 0 function 0
pchb0: Intel 82437FX (Triton) PCI, Cache, and DRAM Controller (rev. 0x01)
pcib0 at pci0 dev 7 function 0
pcib0: Intel 82471FB (Triton) PCI-ISA Bridge (rev. 0x02)
Intel 82438 (Triton) IDE controller (IDE mass storage, interface 0x80, revision 
0x02) at pci0 dev 7 function 1 not configured
de0 at pci0 dev 17 function 0 at irq 14
de0: SMC 21041 [10Mb/s] pass 2.1
de0: address 00:e0:29:0e:f7:99
Matrox MGA Millenium 2064W ("Storm") (VGA display, revision 0x01) at pci0 dev 18
 function 0 not configured
de1 at pci0 dev 19 function 0 at irq 15
de1: DEC 21040 [10Mb/s] pass 2.3
de1: address 08:00:2b:e6:1b:ab
ahc1 at pci0 dev 20 function 0
ahc1: interrupting at irq 15
ahc1: aic7860 Single Channel, SCSI Id=7, 3 SCBs
scsibus0 at ahc1 channel 0: 8 targets
ahc1: target 0 synchronous at 10.0MHz, offset = 0xf
sd0 at scsibus0 targ 0 lun 0: <QUANTUM, XP34301, 1071> SCSI2 0/direct fixed
sd0: 4106MB, 4076 cyl, 20 head, 103 sec, 512 bytes/sect x 8410200 sectors
ahc1: target 1 synchronous at 10.0MHz, offset = 0xf
sd1 at scsibus0 targ 1 lun 0: <HP, C3725S, 6039> SCSI2 0/direct fixed
sd1: 2047MB, 3703 cyl, 9 head, 125 sec, 512 bytes/sect x 4194058 sectors
ahc1: target 2 synchronous at 5.0MHz, offset = 0xf
cd0 at scsibus0 targ 2 lun 0: <MATSHITA, CD-ROM CR-504, ST23> SCSI2 5/cdrom remo
ahc1: target 4 synchronous at 4.0MHz, offset = 0xb
probe(ahc1:4:0): Target Busy
probe(ahc1:4:0): Target Busy
st0 at scsibus0 targ 4 lun 0: <EXABYTE, EXB-8500SMBANXH1, 0458> SCSI2 1/sequenti
al removable
st0: st0(ahc1:4:0): Target Busy
st0(ahc1:4:0): Target Busy
st0(ahc1:4:0): Target Busy
drive empty
isa0 at pcib0
com0 at isa0 port 0x3f8-0x3ff irq 4: ns16550a, working fifo
com1 at isa0 port 0x2f8-0x2ff irq 3: ns16550a, working fifo
com2 at isa0 port 0x3e8-0x3ef irq 5: ns16550a, working fifo
com3 at isa0 port 0x2e8-0x2ef irq 9: ns16550a, working fifo
sb0 at isa0 port 0x220-0x237 irq 10 drq 1 drq2 5: dsp v4.13
audio0 at sb0
npx0 at isa0 port 0xf0-0xff: using exception 16
vt0 at isa0 port 0x60-0x6f irq 1
vt0: generic, 80 col, color, 8 scr, mf2-kbd, [R3.32]
vt0: console
fdc0 at isa0 port 0x3f0-0x3f7 irq 6 drq 2
fd0 at fdc0 drive 0: 1.44MB, 80 cyl, 2 head, 18 sec
biomask 8040 netmask c040 ttymask c042
de0: enabling 10baseT port
boot device: sd0
root on sd0a dumps on sd0b
root file system type: ffs
de1: enabling 10baseT port

Andreas Wrede              Planix, Inc.         Networking, System Administration, Consulting      Toronto, Ontario, Canada