Subject: Re: More pppd news... sort of. :/
To: Mason Loring Bliss <>
From: Paul Goyette <>
List: current-users
Date: 10/01/1997 06:11:03
Don't forget to replace your /usr/sbin/chat with one of the same vintage
as your pppd image.

On Tue, 30 Sep 1997, Mason Loring Bliss wrote:

> On 9/30/97 at 5:59 PM -0400, you wrote:
> > Well, I don't know about why your old pppd is not working for you, but
> > there is a small problem with the new version.  It doesn't set clocal
> > while running the chat script, so the chat script doesn't get run
> > properly.
> Hm... I don't remember seeing a solution posted, but I'll check the
> archives just in case there's something I've missed. Oh, wait. I can't
> check the archives. Drat... Um... Heh! Do you (or does anyone else?) have
> any quick and dirty solutions handy?
> > The above might be the result of your needing to turn the modem
> > off and back on again
> I've tried this several times, and with several durations. It doesn't fix
> it for me. :/
> > BTW, if you are going to be running/following -current, you should
> > subscribe to the current-users mailing list.  Then you'll know when this
> > kind of thing happens :-)  It's been discussed there for about a week.
> I read current-users, and I post to it, probably with an annoying
> frequency. :) The only thing I remember coming up was a problem where the
> default route wasn't set.
> I just snagged the pppd binary from the June 1st mac68k snapshot, and it's
> also 2.3.0b5. This version has worked for me before, and there haven't been
> any changes to /etc/ppp/*. It gives me the expected "serial port looped
> back" message.
> I had an active, working, pretty much flawless PPP connection running this
> morning. I snagged the latest binaries using this PPP connection. I
> installed the binaries, rebooted, and now pppd consistently and
> unswervingly tells me that my serial line is looped back. This hasn't ever
> happened before, and other software has no trouble using the modem. It's
> *just* pppd that is having trouble. Both versions 2.3.0b5 and 2.3.1 are
> giving me this message, which, since I've had 2.3.0b5 working before, leads
> me to believe that the problem may be elsewhere. I can, and do,
> successfully use my modem with uucp, and I can talk to it and get it to
> dial with "cat > /dev/tty01", but pppd can no longer talk. I don't know of
> any software that acts as an intermediary between pppd and /dev/tty01, and
> I know that the hardware is fine, so I assume that the problem lies with
> pppd. However, my pppd configuration hasn't changed, and I've tried the
> older version I had been using, so I assume that the problem doesn't lie
> with pppd. Going by all of these assumptions, I have no problem, and my
> connection works properly. But, as this isn't the case, I must conclude
> that there's some part of this about which I'm unaware.
> <meek voice> Help?
> Side note: I tried running things manually, like so:
> chat -v -f /etc/ppp/manualchat </dev/tty01 >/dev/tty01
> pppd /dev/tty01 38400 modem crtscts defaultroute lock passive
> The chat script I set up seems to be logging me on properly, but pppd
> squeaks to me of the following:
> Sep 30 23:10:32 acheron pppd[2875]: LCP: timeout sending Config-Requests
> Note that when I use Bill's standard ppp-up script, the chat session never
> happens at all. I think pppd is telling me my serial line is looped because
> it's trying to send packets without a modem connection. Just a guess. If
> this is correct, however, then I'm curious as to why pppd behaves
> differently all of a sudden.
> Thanks graciously and in advance for any help offered...
> --
>         Mason Loring Bliss    /\
>   /()\   awake ? sleep() : dream();
> <barbaric>YAWP!</barbaric>  /    \  Squeak to me of love!

| Paul Goyette       | PGP Public Key fingerprint:  | E-mail addresses:     |
| Network Consultant |     0E 40 D2 FC 2A 13 74 A0  |    |
| and kernel hacker  |     E4 69 D5 BE 65 E4 56 C6  | |