Subject: Re: More fsck problems?
To: Martin Cernohorsky <>
From: Luke Mewburn <>
List: current-users
Date: 09/24/1997 19:24:28
"Martin Cernohorsky" writes:
> On Sep 24,  2:52, Dave Huang wrote:
> > I tried booting single user and fsck-ing /dev/rwd0a, and fsck asked "MARK
> > FILE SYSTEM CLEAN?" After I said yes, it says "FILE SYSTEM MARKED CLEAN".
> > So far so good... I try to fsck /dev/rwd0a again, and fsck says "File
> > system is clean; not checking". Still good. But when I "mount -u /", I get
> > the "file system not clean; please fsck(8)" message. Not good :(
> I see the same problem on my machine. Worth noting is, that fsck
> on the block device (ie. "fsck /dev/wd0a") fix it!

I've just committed a patch which #ifdef's out the bits which
were added in lite2 that are the likely culprits. they were:

	file		what the lite2 merge added that i've now disabled
	----		-------------------------------------------------
	main.c		replaced ckfini(1) with hotroot() check and
			then based args to ckfini() on whether fs == "/"

			comment: This is probably the culprit...

	setup.c		sets skipclean = 0 if the superblock can't be read
			(just before the alternate superblocks are tried).

			comment: not sure about this

	utilities.c	saves and restores fsmodified flag around flushing
			of superblock to disk

			comment: again, not sure about this

each bit of code (wrapped in #ifdef LITE2BORKEN) can then be separately
verified by the FS gurus, and the appropriate code chunk used.

for now, functionality should be as per before the merge of lite-2.

once again, sorry about any inconvenience.