Subject: (Unfortunate?) Success...
To: NetBSD-i386 <port-i386@NetBSD.ORG>
From: Mason Loring Bliss <>
List: current-users
Date: 09/18/1997 13:35:40
Well, after I moaned and complained about not being able to get The Malign
Cyrix 486 to work properly, I gave up on it for a couple days. Last night I
was feeling vaguely insomnic, so I gave it another whack. I popped off a
couple jumpers on The Malign Motherboard, and twiddled the BIOS settings
some more. I managed to make the cksum errors I was experiencing go away.

Now, here's why this particular bit of success is unfortunate:

Once I got things looking stable, I tried to boot with the 970901 GENERIC
kernel, and it dumped me into the debugger as described in a recent post. I
can describe it again if it would help. Giving up on this, I tried the next
oldest kernel, from August something-or-other. It also bombed at the same,
exact place. Finally, I tried a GENERIC121 kernel. It booted without
errors, mostly, except for its not being able to find a CD-ROM drive (since
there isn't one) and (I think) the CD-ROM controller... (There isn't one of
those, either. Or a sound card.)

Anyway, I went ahead and installed 121. It works fine, except that I can't
reboot or shut down properly, but that's my fault, since I installed 121
using the 970901 -current boot floppy. (I didn't have the 121 image on a
disk, which meant my options were 1. nuke the hard drive and copy the image
to a floppy, or 2. drive to someone's house to make a floppy. Neither idea
appealed to me. Unfortunately, I didn't realise that shutdown, halt, etc.
weren't part of the base package... I don't think they are, anyway. At
least, I assume they're simply out of sync with the rest of the binaries
and kernel.)

There were only three "running" problems I encountered:

* I get an ioctl (IIRC - I'm not booted from wd0a right now) error when I
do a mount -t msdos /dev/fd0a /mnt2. Oddly, if I don't specify -t msdos, it
has no problems, from what I can see.

* I couldn't seem to talk to my serial port. I tried two different cables,
and neither seemed to work. I turned on the appropriate gettys in
/etc/ttys, gave a kill -1 1, and made sure the gettys were running, and at
the desired speed. I'm not sure what's up with this, but it's a bit of an
annoyance, as the beast is going to have to talk to the world through a
serial port for the foreseeable future. Oh well... It's a start, anyway.

* For some reason, fsck doesn't work. fsck_ffs does, however.

So, things are going, I guess. If there ends up being a bug in the -current
kernels that's causing the panic, I'd be happy to test kernels to help find
out just what's happening. Until I get a modem and a working serial port
for this system, it's not going to run or store anything useful, so I'm not
worried about crashing, rebuilding, and all that.


        Mason Loring Bliss    /\   /()\   awake ? sleep() : dream();
<barbaric>YAWP!</barbaric>  /    \  Squeak to me of love!