Subject: Re: network hang
To: None < (Brain fried. Explanation is in>
From: Jon Buller <>
List: current-users
Date: 09/13/1997 21:17:04
I *think* this happened to my pc532 once as well...  It wasn't too
long ago, I was doing a BIG ftp transfer over a 14.4Kbps modem,
and the pc532 acts as a gateway for a SPARCStation ELC and sometimes
a Mac.  I wasn't using the ELC in any way (like I could get less
than a 1 min response under those conditions.)  Anyway, GTE is really
bad around here, and can only hand out lines good enough to keep the
modem connected for several hours at best.  I thought the line had dropped,
but when I got home, the modem was still alive and kicking! writes:
> AHA!  I'm NOT the only one!
> Wailer sez:
> /*
>  * > I'm using netbsd as a gateway/workstation.  P133/32 with scsi disks.
>  * > I'm having an issue which I've seen off and on for a very long time
>  * > in which the network just clogs up and ceases to move.  I run ppp over
>  * > a v.34 modem attached to a 16550.  Lockups appear to occur with 
>  * > heavy network use, but not always.  This last one happened while a
>  * > client was running cu-seeme, so heavy udp use.
>  */
> Jukka Marin sez:
> /* So your PPP links locks up and starts working only after a modem disconnect
>  * and redial?  I see this every now and then on all my NetBSD 1.2 boxes.  I
>  * was hoping this problem had been solved by the com driver changes in
>  * -current.  I thought there was a handshake problem in the com driver which
>  * sometimes prevented data transmission.. but maybe it's not that, then.  I
>  * haven't used an RS tester to see the state of the handshake signals but
>  * I guess I should do that sometime.  My PPP link usually stays up for a few
>  * days in a row, but on a 486 system we see the problem a few times a day.
> I don't think it's com specific, though -- I'm using a SPARCstation IPX
> [I've just been back and forth a little bit with this on port-sparc; no
> further info just yet...] and I have the exact same problem!
> I experience such anomalies as:
> 	'ftp get' works ok to a point (most of a large (1.3MB) file), and
> 	then kind of bellies up, eventually timing out with Connection reset.
> 	'ftp reget' gets about 12-13kB more and does the above.
> Speed: 19200 (38400 gives "zs0a: fifo overrun"), USRobotics Sportster 28.8
> with compression enabled; pppd with deflate 15/bsdcomp 15, no vj compression
> (since that broke on me once).  Oh well.
>  * 
>  * The problem only affects one PPP link at a time, so I don't think it's
>  * a generic networking problem (Ethernet always works just fine).
>  * 
>  *   -jm
>  */
> No, but it's certainly not restricted to com*.
> 				--*greywolf;
> --
> Humanocentric religions and ways of life have proven to be our undoing.