Subject: Re: hang during shutdown
To: None <scottr@Plexus.COM>
From: maximum entropy <>
List: current-users
Date: 09/12/1997 00:21:34
>From: Scott Reynolds <scottr@Plexus.COM>
>I ran across this last night, and noticed to my dismay that I had /usr
>mounted _twice_.  As soon as I commented out the mounts of specific
>file systems other than root, I was able to reboot successfully.  Note
>that in my case, I couldn't get a clean reboot at any point while
>/usr was mounted twice.
>I'm not sure what the solution is, but one thing that particularly
>troubles me is the potential for `mount /usr' to be performed twice in
>/etc/rc, besides the `mount -a' that is invoked later on.

Odd...I reported the "/usr mounted twice" problem on current-users
when it showed up...and of course that was the first thing I tried
when my system started hanging while dismounting /usr.  My test system
has rc modified so that /usr will not be mounted twice, but it still
hangs every time during the dismount process.

There may in fact be some relationship between these two problems
(they did show up around the same time) but I don't think it's a
simple cause-and-effect.


entropy -- it's not just a good idea, it's the second law.