Subject: Re: README: atapi support merged
To: Ken Wellsch <>
From: Manuel BOUYER <>
List: current-users
Date: 09/04/1997 18:22:46
On Sep 4, Ken Wellsch wrote
> [...]
> I am still a novice but can finally report success - I used cdrecord-1.5a6
> which includes mkisofs 1.11.  I did not have any trouble constructing an
> ISO 9660 type image, and using vnconfig could confirm the contents also
> with ease.  As for talking to our dusty old Yamaha CDR-100 unit, that was
> another matter.  I was finally successful with the 082397 tarball copy of
> 1.2G.  The CDR-100 would appear as "uk0" and when I'd linked /dev/scgx to
> /dev/uk0 I was able to happily burn almost two dozen CD-R's at 4x speed.
> Doing so at 4x speed was a big thrill for me since I was pulling the images
> over the network via NFS, and having tried a couple Adaptec Win'95 based
> "commercial" products, they had trouble even at 1x on occasion - not to
> mention they're dreadfully useless when it comes to writing "proper" files
> UNIX style.
> I was disappointed though when I tried the 090197 snapshot with integrated
> ATAPI to find the CDR-100 now appears to be a CD-ROM (i.e. "cd0") and
> I can no longer "pass through" whatever SCSI activity "cdrecord" is
> trying to do (or that was my best guess as I thrashed about trying
> differing combinations of things).

Opps ! This is a left-over hack from my private tree (to be able to mount
a cd from a cd writer). However, I don't understand wy cdrecord
doesn't work, as it should just pass raw scsi commands to the device,
and the cd driver should do that as the uk driver. Did you use the
raw part  (/dev/rcd0c or /dev/rcd0d on i386) ? Raw scsi commands will not
work if you don't use the raw part.

> Also I know this is pure icing stuff and hardly a priority, but being
> dumb as a fence-post, I'm not sure how to convince "xmcd-2.2" to have
> the correct chat via the new "SCSI" cover to the underlying ATAPI CD-ROM
> unit.  I tried on a couple different machines and "xmcd" could almost
> talk to the drive, but "play" was a definite no-go.

xmcd sends raw SCSI commands, some of them are not understood by atapi CDROM.
You should try the xmcd patch available from in
/pub/NeBSD/unofficial/atapi, or use the FreeBSD ioctl method. This makes
xmcd use audio ioctls instead of raw scsi commands to talk ti the drive.

Manuel Bouyer, LIP6, Universite Paris VI.