Subject: -current make oddity in domestic
To: None <current-users@NetBSD.ORG>
From: William O Ferry <WOFerry+@CMU.EDU>
List: current-users
Date: 08/30/1997 10:23:46
    I sup'ed -current yesterday morning, and set out to make build on my
1.2E i386 system.  I ran into a rather odd problem where while
domestic/lib/libtelnet would seem to build fine, it wouldn't include any
of the functions in encrypt.c.  When making the static and shared
libraries, it would say "nm: encrypt.o: no name list".  When I tried to
make domestic/usr.bin/telnet or domestic/libexec/telnetd, they would
fail to find all the symbols defined in encrypt.c.

    Interestingly enough, this seems to have had nothing to do with
encrypt.c itself.  Since I have 4 different NetBSD platforms on my desk,
I do a "make obj" and have the variables for it set in /etc/mk.conf. 
Just to make sure I removed all of these and rebuilt libtelnet.  When
the obj.i386 directory wasn't there, nm found all of the symbols in
encrypt.o!!  I removed the /usr/obj.i386 directory for libtelnet (to
make sure nothing was lingering around from some earlier compile), did a
"make obj && make depend && make", and once again nm could not find the
name list, just for encrypt.o.

    Does this make sense to anybody?  Is this some kind of problem with
a Makefile or something?  I don't understand enough about how the obj
build procedure differs from the regular one to have any clue what's
going wrong.

    Any suggestions would be appreciated (I'd like to go back to the obj
directories on this directory).  Thanks in advance.

                                                          Will Ferry

 William O Ferry  <woferry@CMU.EDU> | finger: woferry@Warp.RES.CMU.EDU | talk:   finger for online status