Subject: Re: Interesting buglet...
To: None <>
From: Mike Long <>
List: current-users
Date: 08/28/1997 14:08:49
>From: (Brain fried.  Explanation is in file "core".)
>Date: Wed, 27 Aug 1997 20:38:39 -0700

>I picked up -current sources as of about a week ago and ran a 'make depend'
>and aside from running into the standard problems with 'compile_et' and
>'make_cmds', I ran into a unique problem (if only I could reproduce it,
>which I can't since I modified the Makefile :-).  It was in one of the
>fsck* series or something, and it referenced something which was no longer
>in /usr/src/usr.sbin (or /usr/src/sbin).

I have seen this often when a file has been moved in the repository;
e.g. when <vm/lock.h> became <sys/lock.h>.  It happens because make is
using the full pathname of the file which it gets from .depend, and
that pathname is no longer valid.  The problem is easily solved in
each instance by:

# rm {obj/,}.depend; make depend

You can fix it for your whole tree using:

# cd /usr/src; make cleandir && make depend

but that is overkill in most cases.

>More to the point, it'd be nice if someone'd fix the Makefile in question
>for the next sup :-)

There probably isn't anything to fix; but there's no way we can tell
for sure without a log demonstrating the problem.
Mike Long <>      
"Every normal man must be tempted at times to spit on his hands,
hoist the black flag, and begin slitting throats." -- H.L. Mencken