Subject: Re: NTP problem
To: Duncan McEwan <>
From: Jonathan Stone <jonathan@DSG.Stanford.EDU>
List: current-users
Date: 08/26/1997 18:17:53
In message <>Duncan McEwan writes
>I've just tried running xntpd on my current-ish netbsd/i386 and it doesn't
>seem to work too well :-(

>Are there any NTP guru's out there [Jonathan... :-)] who could shed some light
>on what is going on here or tell me where to look to debug the problem

Hi Duncan,

The canonical answer on comp.protcols.time.ntp is to get the latest
patches (5.90.3?)  from UDel and to apply them, and see if that makes
your problem go away.  (Perry: any reason not to pull the latest xntp
5.xx release into the tree?)

if that doesnt' work, I suggest you try configuring MD5 authentication
for broadcast, and see if that helps.  That' sjust a guess, but the
code in our tree seems to expect MD5 in places where 3.5f did not.

I haven't ever tried xntp 5.xx with  broadcast or multicast.

The xntp 5.xx codebase is autoconfig'ed and has a lot more hair and
details to get wrong, as well as support for newer systems (e.g.,
UltraSparcs with Solaris) that require workarounds that're
incompatible with earlier workarounds (e.g., for sun4c/sun4ms).

To be honest the stratum-2 servers I'm running are still using 3.5f.
Ignoring the NetBSD support issues and considering just NTP service,
if 3.5f works, I'd stick with it.

One thing i have noticed is that 3.5f and the 5.90 releases don't use
compatible defaults for authentication and encryption.  I'm behind a
firewall and I'm blase about using plaintext authenticators.  That
works fine with 3.5f. But the xntp code in the NetBSD tree insists on
MD5 keys, despite what my ntp.conf says.

(Probably I have failed to read some relevant documentation, but it's
not mentioned in the manpages in our tree. I know I should UTSL,
it hasn't been important enough yet.)


You're welcome, but I doubt I've helped much :).