Subject: gaaah again! bootinstall troubles
To: None <current-users@NetBSD.ORG>
From: Erik Rungi <>
List: current-users
Date: 07/28/1997 13:03:20
I guess I'm just dumb...

I'm trying to make netbsd-1.2G/i386 co-exist with 2 windoze partitions,
one primary, one extended, then netbsd in table slot 3 (there seems to be
4 primary slots from what I understand from the fdisk(8) manpage). 

I'm trying to make OS-BS go.  It requires a proper partition definition in
this table (BIOS partition table ? according to manpage).

Ok so when table slot 3 is empty, I can boot off of the HD by throwing the
install floppy in and typing "BOOT wd0a:netbsd".  However, if I set this
slot 3 partition ID to 165 (hex A5) which corresponds to NetBSD partition
type as the manpage suggests, I can no longer boot the HD kernel off the
floppy.  If I boot off of floppy and try to mount the NetBSD partition
from floppy I get "incorrect superblock".

However, if I set the system ID to 99 (hex 63) which corresponds to GNU
HURD fs, I can again boot from floppy by specifying the HD kernel (still
not from OS-BS however due to lack of boot loader code it seems).

Furthermore, the disklabel -B flag seems to have disappeared.  I tried
to install the old boot loader code and get OS-BS to recognize that, and
this worked fined except that the old bootloader couldn't get the new
kernel going.  The newish looking "installboot" command seems to make
sense from the manpage, but doesn't actually do anything as far as getting
me closer to having a booting system.

Anyway I'm obviously a bit confused about this whole situation.  If
anybody knows what I'm doing wrong, I would much appreciate being
straightened out.


Openface Internet Inc.                                          Erik Rungi
Montreal, Canada                              
(514) 281-8585                                          Technical Director
Web Services, Software Development                            OpenFace INC