Subject: rpc.bootparamd /diskless boot?
To: current-users <current-users@NetBSD.ORG>
From: Hauke Fath <hauke@Espresso.Rhein-Neckar.DE>
List: current-users
Date: 07/14/1997 23:28:23

for some days I've been trying to set up an old i386 pizza box as a
diskless workstation/ISDN router. It comes with an NE2000 clone e'net card
that is recognized as ed0 by kernels built from 18 Jun snapshot sources.
Unfortunately, a boot PROM built from "arch/i386/stand/netboot" sources
does not see the card.

Booting the kernel from floppy would do for a start. I tried to mount the
i386 fs from a mac68k system via bootparam & nfs; while I can do the nfs
mounts just fine after booting from one of the new boot floppies, the
bootparam stuff doesn't work at all.

On the wire this looks like (seen from a third machine; "filter" is
"ether host 00:00:01:00:08:57 or ether proto \rarp or ether proto \arp
	or host"      )

>[hauke@q700] ~ # tcpdump -vv -n -F filter
>tcpdump: listening on sn0
>22:07:16.341316 rarp who-is 0:0:1:0:8:57 tell 0:0:1:0:8:57
>22:07:16.402909 rarp reply 0:0:1:0:8:57 at
>22:07:16.402910 arp who-has tell
>22:07:16.402911 > udp 96 (ttl 64, id 0)
>22:07:17.342310 > udp 96 (ttl 64, id 1)

bootparamd(8) on espresso says

>Jul  8 22:04:56 espresso rpc.bootparamd: whoami got question for
>Jul  8 22:04:56 espresso rpc.bootparamd: This is host
>Jul  8 22:07:26 espresso rpc.bootparamd: Returning doze nauseam.

The very first contact from the client solidly wedges the bootparam server:

>[hauke@q700] ~ > rpcinfo -u espresso bootparam 1
>rpcinfo: RPC: Timed out
>program 100026 version 1 is not available
>[hauke@q700] ~ >

-- which has worked before and can only be cured by rebooting the server

(Btw: diskless(8) has not proven very helpful in my case as it concentrates
on HPs and SUNs.)

Comments, insights, anything? Does "bootparam" work for anyone with -current?


"It's never straight up and down"     (DEVO)