Subject: System crashing after load runs away - solved.
To: None <current-users@NetBSD.ORG>
From: D'Arcy J.M. Cain <>
List: current-users
Date: 06/23/1997 12:23:03
I saw a few mentions of something that sounded a lot like this problem
that I have on this list and although it didn't sound exactly the same, I
thought I would describe the problem I was having and how I solved it.
I hope I haven't missed a fuller discussion on the list.  A few mailing
lists I am ongot really busy lately and I have been skimming a lot.  My
apologies if I am chewing old fat.

Anyway, here are the symptoms and the solution.  I would be working on
various things when suddenly the load would skyrocket.  If I didn't catch
it in time and reboot (seldom able too) it would stop responding.  The
kernel seemed to be alive (ping worked) but basically it needed a hard
reset.  Finally I tried to build a debugging kernel and it crashed on
the link stage every single time.

It seems that at one time the system would set up swap when you booted
based on the information in the disk label.  Very recently it seems that
this stopped and you need the swap lines in your /etc/fstab file.  I
didn't have this so as a result I was running without any swap space
as shown by "swapctl -l."  I solved my problem by adding the following
lines to /etc/fstab:

/dev/sd0b none swap sw
/dev/sd1b none swap sw

Use disklabel to confirm where your swap partitions are.

Again, sorry if this has all been explained in detail and I missed it.

D'Arcy J.M. Cain                           |  Democracy is three wolves
darcy@{|}                  |  and a sheep voting on         
+1 416 424 2871     (DoD#0082)    (eNTP)   |  what's for dinner.
                --  --