Subject: Insight in failure in xosview with 1.2G
To: None <current-users@NetBSD.ORG>
From: Dave Burgess <>
List: current-users
Date: 06/19/1997 13:00:59
I've got two programs that are failing with 1.2G:

1.  xosview (an X status program, like xload but more)

I tried running it under gdb, and it gets as far as the query for the
swap and consistently fails with the following:

Program received signal SIGSEGV (11), Segmentation fault
0x722f in ?? ()

I tried backtracing (just cuz I always do) and it is definitely a jump
to NULL.

The display (which I can't paste in) has the load, the CPU utilization
and the memory use.  These numbers all appear to be correct.  The swap
utilization is next, and it is not listed.  I also tried compiling with
-g to get the debugging symbols included, but that doesn't want to work

2.  mvend (a shopping cart app which runs under Perl5.004) is hanging; 
the vend program seems to be hanging, because the message about the 
server being too busy gets generated.  The problem seems to be in the
Perl program.  This one is kind of baffling; we'll see if a relink is
enough.  mvend uses a lot of network code to manage the connections.  I
can't really give you more info than that right now; just trust me that
there seems to be a problem.

Dave Burgess                   Network Engineer - Nebraska On-Ramp, Inc.
*bsd FAQ Maintainer / SysAdmin for the NetBSD system in my spare bedroom
"Just because something is stupid doesn't mean there isn't someone that 
doesn't want to do it...."