Subject: 1.2G, fatal page fault in supervisor mode
To: None <current-users@NetBSD.ORG>
From: Erik Bertelsen <>
List: current-users
Date: 06/17/1997 10:13:19
In the last few days (i.e. after the new swap handling), I have had
problems upgrading my NetBSD/i386 to current. This problem has persisted
since the upgrade to 1.2G, and now I'm at yesterday's SUP.

The kernel boots, but after starting the rpc daemons (it prints the daemon
names and ends with the ".") it dies. 

The following is a quick write-down of the error messages as I have
collected them before the system reboots:

cksum: out of data
fatal page fault in supervisor mode
tt 6 c 0 eip f810039e cs 8 eflags 10216

(the actual words are longer, but the numbers should be correct).

I then discovered that I have left out DDB from this kernel and now
I rebuilt the kernel with options DDB,DIAGNOSTIC to get a traceback.

What happens: The kernel now boots completely to multi-user and serves
the X display where I write this message. 

I thought that the debugger was there to identify bugs, not to make them
go away :-) :-) :-)

Any ideas? or explanations ?

Below is the dmesg output in case that the hw/driver configuration
may be part of the problem.

Erik Bertelsen

NetBSD 1.2G (ERIKBE) #33: Tue Jun 17 11:55:58 MEST 1997
cpu0: family 5 model 2 step c
cpu0: Intel Pentium (P54C) (586-class)
real mem  = 33161216
avail mem = 29499392
using 430 buffers containing 1761280 bytes of memory
mainbus0 (root)
pci0 at mainbus0 bus 0: configuration mode 1
Intel 82439 (Triton II) TXC Host Bridge (host bridge, revision 0x03) at
pci0 dev 0 function 0 not configured
pcib0 at pci0 dev 7 function 0
pcib0: Intel 82371SB (Triton II) PCI-ISA Bridge (rev. 0x01)
Intel 82371SB (Triton II) IDE controller (IDE mass storage, interface
0x80) at pci0 dev 7 function 1 not configured
S3 ViRGE (VGA display, revision 0x06) at pci0 dev 15 function 0 not
isa0 at pcib0
ep0 at isa0 port 0x300-0x30f irq 7: 3Com 3C509 Ethernet
ep0: MAC address 00:20:af:76:4b:10
ep0: 8KB byte-wide FIFO, 5:3 Rx:Tx split, utp/aui/bnc (default bnc)
com0 at isa0 port 0x3f8-0x3ff irq 4: ns16550a, working fifo
com1 at isa0 port 0x2f8-0x2ff irq 3: ns16550a, working fifo
wdc0 at isa0 port 0x1f0-0x1f7 irq 14
wd0 at wdc0 drive 0: <Maxtor 72004 AP>
wd0: 1916MB, 3893 cyl, 16 head, 63 sec, 512 bytes/sec
wd0: using 16-sector 16-bit pio transfers, lba addressing
wdc1 at isa0 port 0x170-0x177 irq 15
wd1 at wdc1 drive 0: <Conner Peripherals 850MB - CFS850A>
wd1: 812MB, 1651 cyl, 16 head, 63 sec, 512 bytes/sec
wd1: using 16-sector 16-bit pio transfers, lba addressing
npx0 at isa0 port 0xf0-0xff: using exception 16
vt0 at isa0 port 0x60-0x6f irq 1: unknown s3, 80 col, color, 8 scr,
mf2-kbd, [R3.32]
fdc0 at isa0 port 0x3f0-0x3f7 irq 6 drq 2
fd0 at fdc0 drive 0: 1.44MB 80 cyl, 2 head, 18 sec
biomask c040 netmask c0c0 ttymask c0c2
boot device: wd0
root on wd0a dumps on wd0b
root file system type: ffs