Subject: Re: Flakiness in build
To: Rick Byers <>
From: Raymond Wiker <>
List: current-users
Date: 06/11/1997 10:41:51
Rick Byers writes:
 > On Tue, 10 Jun 1997, Martin Cernohorsky wrote:
 > > > A friend that bought some cut-rate DRAMs saw exactly this sort of
 > > > behavior.  Things would mostly be ok, but compiles would fail with
 > > > intermittent off-the-wall gripes.  Replacing the newly acquired junk
 > > > DRAM with good Micron DRAM cured the problem.
 > > 
 > > Hmm, is there any possibility to verify the function of the upper part
 > > of the RAM simpler way than physically removing the DRAM in question
 > > (i. e. something like configuring the size of the RAM during boot
 > > time)?
 > Hmm... It's too bad it's not more common.  It's hard to verify when it's
 > working and when it's not.  I started a little test program that just
 > allocates 40Mb, fills it with a known sequence, and then checks it.  So
 > far, it hasn't failed.  It's not perfect, but if it does fail, I'll know
 > it's not a bug in make or anything (I think I allready know that).  Oh, I
 > should mention, Linux gave a similar compiling error last night as well
 > (gcc gave a syntax error, but starting make again worked fine).  Now I
 > just have to find where the memory is with the problem.  I wonder if there
 > is any way to make a certain area of memory not-usable (if it is just a
 > certain part) - I guess you could just allocate it from the kernel at
 > bootup, but you'd have to stop it from being paged.

	I had a similar problem when I was setting up a machine with a
genuintel Pentium 133 and 16 megs of 4MB, 80 ns SIMMS. I could get
FreeBSD up and running on it; but programs would sometimes crash for
no reason. Win 95 on the same machine was completely unusable.

	I then switched to an AMD K5-133, which worked like a charm,
and later upgraded to 64 megs of 32MB, 60 ns SIMMS. I have been
thinking of trying the Pentium chip again, but I guess I won't bother.

	To summarise: I had the same problem, and solved it by
replacing the Pentium chip with a an AMD equivalent. The problem may
have been a faulty processor, or some sort of mismatch between the
Processor, motherboard and memory; in any case, the symptoms were
similar to what you're seeing.