Subject: Q: SMC EtherPower 10/100 PCI problem
To: None <current-users@NetBSD.ORG>
From: Jaromir Dolecek <>
List: current-users
Date: 05/29/1997 22:35:59
I'm having trouble to run this card under NetBSD/i386 1.2.1
When bootings INSTADP kernel, dmesg says:

de0 at pci0 dev 10 function 0: DS21140 [10-100MB/s] pass 2.0
de0: Ethernet adress ...
de0: enabling 100baseTX UDP port
de0: interrupting at irq 10

I typed:
ifconfig de0 netmask 0xffffff00
route add defaul (router on this net)

But afterwards ping to failed and so does ping

ifconfig de0 shows:
	inet ...

As there is no man page for de driver (or at least I've not found
anything other than de(4) for vax, which seems rather inaccurate),
I don't know very much, which flag I can use. I've not found anything
even in BSD FAQ, so I've tried brute force,
all combinations of link0, -link0, link1,-link1, but nothing gets it to
work. I would assume that -link0 is good (driver writes 
'de0: enabling 10baseT UTP port' to console), but it hasn't work either.

I've tried to use 1.2 kernel and it didn't work either.
BUT - w/ -current kernel all just worked out of box. 

Is there any chance I can make it work under 1.2{.1} ?
I've tried to replace 1.2's dev/pci/if_de.c w/ -current version, but it didn't
work, of course ;-)

Thanks in advance for help (or for at least affirmation I have to go -current)


Jaromir Dolecek             	ICS MU, Botanicka 68A, Brno, 60200, Czech Rep.			Tel.: +42-5-4151 2266
It is better never to have been born.  But who among us has such luck?
One in a million, perhaps.
Naše poslání v životě není mít úspěch, 
ale v dobré náladě pokračovat v chybování.