Subject: Re: SCSI problem in -current? (port-mac68k)
To: Paul Goyette <>
From: Scott Reynolds <>
List: current-users
Date: 05/15/1997 08:38:29
On Thu, 15 May 1997, Paul Goyette wrote:

> I just tried booting a kernel supped from yesterday (14 May), and got some
> very strange results:

Hmm.  I should have expected that, I guess.

> First, during the probing of the SCSI bus, it appears that it is now
> trying to probe all 8 LUNs on SCSI unit 0 - something that it hasn't tried
> to do since NetBSD 0.9!

Well, that's strange, and I can't explain that one.  Perhaps it's related
to the following, though.

> [...]
> Thinking that maybe my disk had gotten somehow messed up, I immediately
> tried an `fsck /' and it complained about not finding fsck_ffs - the `ls
> -l fsck_ffs' gave the same error as above!

I discovered late last night -- shortly before I nearly fell asleep on my
keyboard -- that something in the recent m68k libkern changes broke.
Jeremy Cooper (sun3x) observed that stat()'ing filenames with >= 8
characters was broken, specifically.  We're both going to take a look at