Subject: SCSI problem in -current? (port-mac68k)
To: current users <current-users@NetBSD.ORG>
From: Paul Goyette <>
List: current-users
Date: 05/15/1997 06:15:02
I just tried booting a kernel supped from yesterday (14 May), and got some
very strange results:

First, during the probing of the SCSI bus, it appears that it is now
trying to probe all 8 LUNs on SCSI unit 0 - something that it hasn't tried
to do since NetBSD 0.9!

Then, when I tried to `mount -u /' it told me that it couldn't find
/usr/sbin/mount_ffs - of course I was appalled, since (AFAIK) mount_ffs
belongs in /sbin, not /usr/sbin.  So, I did an `ls /sbin/mount_ffs' and
the file was there.  But, when I did `ls -l /sbin/mount_ffs' it told me
that there wasn't any such file (exact error message escapes me, but it
showed me the filename, and then said the file didn't exist)!

Thinking that maybe my disk had gotten somehow messed up, I immediately
tried an `fsck /' and it complained about not finding fsck_ffs - the `ls
-l fsck_ffs' gave the same error as above!

Well, at this point I gave up, and rebooted my working kernel from 28th
April, in single-user mode.  I looked and all the missing files had
magically reappeared.

So, anyone got any ideas?  (BTW, I'm rebuilding another kernel from
today's sup, although the only thing that appears to have changed in the
kernel is signal.h which shouldn't have anything to do with this problem.)

| Paul Goyette       | PGP Public Key fingerprint:  | E-mail addresses:     |
| Network Consultant |     0E 40 D2 FC 2A 13 74 A0  |    |
| and kernel hacker  |     E4 69 D5 BE 65 E4 56 C6  | |