Subject: RealAudio 3.0
To: None <current-users@NetBSD.ORG>
From: Rick Byers <>
List: current-users
Date: 05/04/1997 22:17:43
Hello all, I know a lot of changes have been made to the OSS audio
support, and I havn't seen any mention of RealAudio since the changes. 
Perry did mention that FreeBSD audio was supposed to work as a result of
the changes.  I have seen messages describing some success with the linux
realaudio.  I'm using NetBSD/i386-current as of Apr 28, there doesn't
appear to be any changes to OSS since I upgraded.

What is the difference between /dev/audio and /dev/sound?  Which should be
used for /emul/freebsd/dev/dsp and /emul/linux/dev/dsp?  Oh, BTW, I have
an old SoundBlaster pro (dsp 3.02) on an i386.

Anyway, I tried both the FreeBSD version and the Linux version (both with
16 bit mode disabled).  The freebsd version terminates with signal 11,
apparently after getting some "invalid argument" errors on some ioctl's to
/dev/dsp (which I linked to /dev/audio) and /dev/mixer.  For example:
   381 raplayer CALL  ioctl(0x5,_IOWR('P',0x9,0x4),0xf7bfd32c)
   381 raplayer RET   ioctl -1 errno 22 Invalid argument
which is on /dev/dsp, and:
   381 raplayer CALL  ioctl(0x6,_IOR('M',0xfe,0x4),0xf7bfd34c)
   381 raplayer RET   ioctl -1 errno 22 Invalid argument
which is on /dev/mixer - this is the one that actually generates the
SIGSEGV.  I assume this just means the OSS support isn't finished yet.

The Linux one was somewhat more successfull.  It outputs pretty well, but
often "skips" (repeats the same sample multiple times).  Several times it
locks up entirely, sometimes with no apparent reason, but it allways
happens when I try to restart a finished file or change the volume.  After
sending a "kill -KILL", it takes about 30 seconds or more to actually die. 
It appears to be stuck in an ioctl: 
   254 raplayer CALL  ioctl(0x5,_IO('P',0x1,0),0)
I also still get some ioctl errors:
   400 raplayer CALL  ioctl(0x5,_IOWR('P',0x9,0x4),0xf7bfd3bc)
   400 raplayer RET   ioctl -1 errno -22 Unknown error: 4294967274
 which is on /emul/linux/dev/dsp.
I would guess it's some sort of interrupting problem, maybe the driver is
waiting for the interrupt from the hardware, but mises it for some reason
(but what do I know...)?

Anyway, what is the status of the OSS audio (and soundblaster audio in
general)?  Has anyone had better success with the linux version than I?
Any sucess with the FreeBSD one (I'm using the statically linked one BTW).


Rick Byers                                      Internet Access Worldwide                                      System Administrator
Welland, Ontario, Canada                                    (905)714-1400