Subject: Re: Talk, Telnet LINEMODE and CR's
To: Rick Byers <>
From: Robin Carey <>
List: current-users
Date: 04/21/1997 10:41:14
On Fri, 18 Apr 1997, Rick Byers wrote:

> Hi,
> I've noticed that talk no-longer treats ENTER properly when in Telnet
> LINEMODE.  It just sends/prints ^M instead of going to the next line.  ^J
> does what ^M should do.  Character mode, however, works as expected.  The
> telnet crlf option doesn't change anything. I'm not sure when exactly this
> started happening, but I'm sure it worked at one point.  It works fine on
> my 1.2 machine.
> I've got 1.2D/i386 (a few days old).  I've got ncurses installed, but
> seperate from the existing curses, so it shouldn't interfere.  The problem
> arrises if I link to ncurses as well.
> The problem doesn't appear to be in talk or ntalkd itself since talk
> hasn't changed since 1.2 and I reverted to the 1.2 ntalkd with the same
> effect.  I would expect it something with telnet/curses but everything
> else (including other curses stuff) works fine.
> Anyone else see this?  Any suggestions?

I'd suggest trying: Break into telnet> prompt and then try mode -litecho
which should disable literal character echoing and hopefully get rid of
the ^M's ....

BTW: Can someone remove my E-mail from these mailing lists please ?
I tried doing it via majordomo .... but it didn't work.

My E-mail:

> Thanks,
> 	Rick
> =========================================================================
> Rick Byers                                      Internet Access Worldwide
>                                      System Administrator
> Welland, Ontario, Canada                                    (905)714-1400