Subject: Kernels that won't boot - why?
To: None <current-users@NetBSD.ORG>
From: David Jones <>
List: current-users
Date: 04/12/1997 15:24:03
I'm having problems building kernels for netbsd-i386.

I am using a NetBSD-1.2 current kernel from Feb. 14.  It works fine.

- I can't compile kernels using kernels that I compile myself.  That is,
  I can boot with the stock NetBSD-1.2 generic kernel, and then compile
  my own kernel from source.  That new kernel boots fine and works for what
  I want it to do (IP routing/firewalling).  But, if I try to compile
  kernel sources with my new kernel, I get strange compilation problems.

  Typical are preprocessor or parse errors from gcc.  The errors refer
  to lines in the source that don't exist.  It's like the filesystem is
  getting confused and reading random garbage at times so that bits of
  another source file are appearing in the file being compiled.

  This does NOT happen with the generic kernel.

- So, in an effort to compile a new kernel, I tried using the generic
  kernel GENERICADP from the 1.2 distribution.  If I boot it from the
  GENERICADP floppy, it runs fine.  But, if I copy it to my hard drive,
  and boot from that, the PC resets itself immediately after the
  kernel loads.  I don't know if I'm getting error messages - the time
  between kernel done loading and the reset is ~0.1 second.

I'm at a loss here - the generic kernel worked for me before (I was able
to install NetBSD on this machine in the first place!)  There's
nothing wierd in the machine.  It's a router, with NE2000 clone Ethernet
cards at 0x280 and 0x300, and an internal modem.

I've already upgraded GCC, config, etc. to that required to build a
-current kernel of Feb. 14.

Any ideas?