Subject: Re: Some problems :(
To: Patrick Welche <>
From: Jason Thorpe <>
List: current-users
Date: 04/10/1997 11:54:49
On Thu, 10 Apr 1997 16:08:17 +0100 (BST) (Patrick Welche) wrote:

 > base# modload -dv /usr/lkm/if_ipl.o
 > ld -A /netbsd -e _xxxinit -o /usr/lkm/if_ipl -T 0 /usr/lkm/if_ipl.o
 > Undefined entry symbol `_xxxinit'
 > /usr/lkm/if_ipl.o: Undefined symbol `_ipl_detach' referenced from text
 > segment
 > ld: Spurious undefined symbols: # undefined symbols 2, reported 1
 > modload: can't prelink `/usr/lkm/if_ipl.o' creating `/usr/lkm/if_ipl'
 > base# modload -dv -e if_ipl_lkmentry /usr/lkm/if_ipl.o
 > ld -A /netbsd -e _if_ipl_lkmentry -o /usr/lkm/if_ipl -T 0
 > /usr/lkm/if_ipl.o
 > /usr/lkm/if_ipl.o: Undefined symbol `_ipl_detach' referenced from text
 > segment
 > modload: can't prelink `/usr/lkm/if_ipl.o' creating `/usr/lkm/if_ipl'

...Apparently this hadn't yet been addressed (there was a bug report
about it), so I committed a fix for this just now.

 > The same sort of thing happens with cd9660 but with loads more errors!
 > (I haven't tried any others)

...Please post the errors.  We can't fix them without knowing what's wrong :-)

 > Also, I get lots of timeout errors from
 > mount -t msdos /dev/fd0a /mnt
 > I haven't tried it before.

...again, please post the errors.  Also, which architecture?  There are
several floppy drivers in the tree.  :-)

Jason R. Thorpe                             
NASA Ames Research Center                               Home: 408.866.1912
NAS: M/S 258-6                                          Work: 415.604.0935
Moffett Field, CA 94035                                Pager: 415.428.6939