Subject: Re: ip reassembly time exceeded?
To: None <current-users@NetBSD.ORG>
From: Christoph Badura <>
List: current-users
Date: 01/28/1997 02:51:00 (Jukka Marin) writes:
>> I suppose that there is some kind of network problem between your site
>> and "" or a broken TCP/IP implementation on the
>> MS system which is somehow doesn't show up with larget packets.

>Well, everything always worked fine if I sent mail from the PPP gateway
>machine.  The problems appeared when I started sending mail from other
>machines, connected to the PPP gateway with Ethernet:

>Sending mail from <PPP gateway> always worked.  Sending mail from <A> didn't
> - until I changed the PPP MTU to 576.  First I thought it was the Amiga 3000
>that I was using as a gateway - but replacing that with an i386 box didn't

The reason it works from your PPP gateway but not from the machines
behind it is that when sending from the PPP gateway the kernel send a
256 byte TCP segment (296 byte IP packet) because it knows the that
the segment is going out over interface with the 296 byte MTU.  For
the systems behind your gateway, the kernel only knows that it is
sending via a gateway, so it uses a 512 byte TCP segment (which
clearly shows up in your tcpdump output).  The gateway then fragments
the 552 byte packet into two IP fragments because of the 296 byte MTU
on the PPP link.

Why the Microsoft system sends you an "ip reassembly time exceed"
message is still an open question.  Perhaps you're experiencing a high
rate of packet loss somewhere on the path.  Perhaps there's a
misconfigured router dropping certain IP fragments.  Perhaps MS TCP/IP
stack is broken.

Christoph Badura

You don't need to quote my .signature.  Everyone has seen it by now.
Besides, it doesn't add anything to the current thread.