Subject: Re: some more debug info for the apm problem
To: None <current-users@NetBSD.ORG>
From: Guenther Grau <>
List: current-users
Date: 01/16/1997 18:57:12

I don't have any knowledge about apm and the wd drives, but this sounds
to me like it would be a timing problem. In a previous message you said, that
executing the scripts by hand worked fine.

> So apmd tryes to start /etc/apm/resume, but fails on some strange reason?

Maybe the apmd tried to wakeup the wd/wdc0. After that the hd has to spin up.
And while it's spinning up, the apmd is trying to read some stuff from the
hd which is not yet ready. Maybe the inode for the /etc/apm/resume was still
in the cache, byt when trying to read from this inode the drive just answers
with nulls, because it's not yet ready to read the data.
Of course, this might be just another brain fart :-) Just guessing ... :-)
You might be able to put a sleep in the apmd before it tries to read the
/etc/apm/resume file. (although the error is likely to be in the wd part,
which most likely wans't designed with apm in mind :-)


P.S.: I haven't forgotten to prepare the copy of the bill for you.
You'll get it soon :-)