Subject: Re: devfs (was Share common code/data across ports?)
To: None <>
From: matthew green <>
List: current-users
Date: 01/12/1997 14:10:19
    * every tried to boot a solaris disk on a machine that it wasn't installed
    * on, and wasn't configured basically identically ?  ever tried booting
    * from a disk that previously didn't exist ?
   Rubbish:  boot -rs[v] and it should work just fine.
   You might need to supply the -b flag as well and perform all the startup
   to single-user manually.

oh really?

here's what happened to me:

i installed on a disk when it was on controller 0, scsi id 3.  i
actually wanted this to be controller 1, scsi id 1.  so, i moved
it.  when i booted, it failed to fsck, couldn't mount root or
user, and halted.  ok, i thought, `boot -rvsb' should fix this.
uh uh, said solaris!

the problem was this:

there were no devices for c1t1.  ie, i could not mount c1t1.  as
i couldn't mount the root filesystem, i couldn't _modify_ it.

for some reason i never determined, even booting from the cdrom,
doing a chroot, devlinks, disks, etc. etc., wasn't enough to get
the devices on that disks /devices and /dev.  i ended up having
to reinstall the OS from scratch, with the disk in it's correct