Subject: Re: crash (NCR driver?)
To: Current Users <current-users@NetBSD.ORG>
From: Davyd Norris <>
List: current-users
Date: 01/10/1997 14:53:01
Davyd Norris wrote:
> Could I be having PCI contention problems? Termination problems? I don't have to
> change any jumpers on the NCR when I move the CD over, I just plug it into the
> external connector on the card and reboot. Have I missed a termination? I thought
> I would know all about it if the termination was faulty.
> The problems I get with the new driver code are always script errors, and always
> within the first five minutes or rebooting - usually within the boot period. If I
> boot OK, I can sometimes login (doesn't matter whether single or multi user) and
> then if I start to exercise the disk it yells.

OK - update since this and Dave Huang's letter.

I just compiled the latest sources into a kernel and tried it. Looks a little better 
than the last stuff - I got nearly 10 minutes out of the thing until all hell broke 

This time I tried plugging the tape drive and CD-ROM into the back. All I did was plug 
in and turn on with no worries (I did not set any jumpers Dave - but I have been 
running without a hiccup for 2 years now without touching jumpers - a little worrying)
The CD-ROM is fine, but the tape drive explodes with script errors like crazy. In the 
end I had to turn it off to get the thing to boot.

With or without the CD-ROM I get the same problem now, but this time I only saw one 
script error from the driver. that error came after getting one of the following, 
which was the thing that wedged my system every time from startup to minutes down the 

sd0: SCSI Phase error fixup: CCB already dequeued 0xf86f1400

then if I waited I got a timeout and a skip of 0xf86f1400

This was the same number and error each time. Boot with the 1.20 driver and everything
is just peachy.

BTW, how do I get the 1.20 ncr.c driver file? Is there an archive for it or a set of 
reverse patches?

As always, any info appreciated.

Davyd Norris - Systems Manager
Franklin Collins Pty. Ltd.
Melbourne, Australia.