Subject: 1.2B snap and my disks.
To: None <current-users@NetBSD.ORG, port-sparc@NetBSD.ORG>
From: David Gilbert <>
List: current-users
Date: 01/06/1997 18:17:13
	I'm having trouble with my machine (sigh), and PK said it may
have been due to a writeback cache bug that only affects the 4/260 in
1.2.  So, I an attempt to get a more stable machine, I have tried to
install 1.2B.  However, it doesn't recognise my disks.

	Under 1.2, my SMD drives configure as follows:

xdc0 at vmel0 addr 0xffffee80 vec 0x44 pri 3: Xylogics 753/7053, PROM=2186.02.22
xd0 at xdc0 drive 0: ready
xd0: <NEC D2363 cyl 964 alt 2 hd 27 sec 67>, pcyl 964, hw_spt 68
xd0: 851MB, 964 cyl, 27 head, 67 sec, 512 bytes/sec
xd0: warning: invalid bad144 sector!
xd1 at xdc0 drive 1: ready
xd1: WARNING: no `pcyl' in disk label.
xd1: WARNING: guessing pcyl=964 (ncyl+acyl)
xd1: <>, pcyl 964, hw_spt 68
xd1: 851MB, 964 cyl, 27 head, 67 sec, 512 bytes/sec
xd1: warning: invalid bad144 sector!
xd2 at xdc0 drive 2: off-line
xd3 at xdc0 drive 3: off-line

	No... most of this mess, I gather, is due to things that the
disklabel program is lacking in regards to xd drives.  In fact, when I
try to label the drive, I get:

[3:4:304]root@repeat:~> disklabel -R xd1 xd1.label 
disklabel: ioctl DIOCWDINFO: Read-only file system

	Now... I don't get a complaint when I use -R -r, but I do get
a strange complaint from 1.2B (something about can't access cylinder
1/0/0).  I also seem to get more info about soft ECC corrected errors
from 1.2B

	I gather a bunch has changed.  My xd0 seems to work OK under
1.2B, but my xd1 shows up with no disk label, and using the disk label
command doesn't help matters.

	Can anyone help?


|David Gilbert, PCI, Richmond Hill, Ontario.  | Two things can only be     |
|Mail:         |  equal if and only if they |
|               |   are precisely opposite.  |