Subject: Re: NetBSD hard/software information page?
To: None <current-users@NetBSD.ORG>
From: der Mouse <mouse@Holo.Rodents.Montreal.QC.CA>
List: current-users
Date: 01/03/1997 21:50:11
> Is there any document containing information about NetBSD hardware
> and software compatibility?  I know there are lists of "supported
> hardware" for many architectures, but if the support is something
> like "well, we have a driver for that thingummy, but last time I
> tried, the driver didn't even compile" then it's not worth much.

Or if it's "well, last time I tried that, it worked, but I haven't had
one of those cards in my machine in three years".

And of course there are all the lovely interactions between pieces all
long-time sysadmins know far more than they'd like to about....

> I've been thinking of writing a WWW page and listing all software and
> hardware that _I_ am using under NetBSD on various machines.

I think collecting and collating this information is an excellent idea,
especially if people are willing to volunteer as contact points, the
sort of thing like "Well, the FrobozzCo image grabber is a really cool
board but it's a bit funky, I had to play with it to get it working,
I'll be glad to talk with anyone having trouble with it".

Personally, I've been running NetBSD/sparc on an IPC (I think - the
machine's at work, I'm not), with an internal disk of about 1G (a
Seagate ST31200N) and at various times from zero to about three
external SCSI devices of assorted sorts.  I use the onboard Ethernet
for routine network connectivity and have a second SBus Ethernet card
("le1 at sbus0 slot 1 offset 0xc00000 pri 5") in the machine; there was
one period of about three days during which the machine handled
gatewaying between two networks in an unusual way (an encapsulated
tunnel setup), and it stood up well.  The builtin floppy drive has
worked for me, but I haven't stressed it.  I've used the machine both
headed ("bwtwo0 at sbus0 slot 3 offset 0x0") and headless ("zs0 at
mainbus0 ioaddr 0xf1000000 pri 12, softpri 6" / "zs0a: console i/o")
and they both work, though the headless console serial line fairly
reliably drops one character if output is in progress when certain tty
state changes are done.  (I haven't investigated this in detail (a)
because it hasn't been a major pain for me, (b) I haven't had much time
to spare, and (c) the machine is still at 1.2, so it could be fixed in
current, especially since I think I saw some source-changes messages
about missing delays in the zs driver.)

At home, I have two Sun-3/260s, one of which has 64 megs of RAM (two
32-meg boards), one SCSI interface, and a cg2 console (the net
connection is the Ethernet on the cpu board); the SCSI chain is the

si0 at vmes0 addr 0xff200000 level 2 vector 0x40 : options=3
scsibus0 at si0
sd0 at scsibus0 targ 0 lun 0: <IBM, WDS-L160, S510> SCSI1 0/direct fixed
sd0: 163MB, 1923 cyl, 4 head, 43 sec, 512 bytes/sec x 334601 sectors
sd2 at scsibus0 targ 1 lun 0: <SEAGATE, ST15230N, 0498> SCSI2 0/direct fixed
sd2: 4095MB, 3992 cyl, 19 head, 110 sec, 512 bytes/sec x 8386733 sectors
sd4 at scsibus0 targ 5 lun 0: <IOMEGA, ZIP 100, C.19> SCSI2 0/direct removable
sd4: drive offline
st2 at scsibus0 targ 6 lun 0: <TANDBERG, TDC 3800, =03:> SCSI2 1/sequential removable
st2: rogue, drive empty

Yup, I've got a zip drive on there, and for those who don't know the
Tandberg 3800, it's a QIC (quarter-inch cartridge) tape drive capable
of writing DC6525s (about 500 megs per cartridge).  You may note
"options=3"; the lack of disconnect/reconnect is a major pain when
using the tape drive, but if you don't want to use the system for
anything else at the time (or don't mind _really_ sluggish response) it
does work.  I tried options=7 but it fell over pretty hard before even
touching the tape drive; I haven't investigated since.

The other -3/260 has 24 megs of RAM (three 8-meg boards), two SCSI
interfaces, and a cg2 console.  One SCSI chain is an "si" interface
plugged into one of the Multibus-to-VME adapter frames that puts the
SCSI chain on the backplane P2 connector (the kind that has to go in
slot 7 of the 12-slot cardcages); I removed the backplane connector
from the Sun cable and put it on my own ribbon cable, bringing the SCSI
chain out through front-panel hole designed to give access to the
internal tape drive.  The other is another "si" in the other sort of
adapter, with the SCSI chain brought out to a back-panel DB50F.  Here's
what's on the SCSI chains.  si0 is the one with the back-panel
connector; si1 is the one with the P2 backplane connector.  (The kernel
has hardwired assignments for sd0 through sd7; not all of these devices
are normally left turned on.)

si0 at vmes0 addr 0xff200000 level 2 vector 0x40 : options=3
scsibus0 at si0
sd0 at scsibus0 targ 0 lun 0: <SEAGATE, ST12400N, 8650> SCSI2 0/direct fixed
sd0: 2048MB, 2621 cyl, 19 head, 84 sec, 512 bytes/sec x 4194685 sectors
sd8 at scsibus0 targ 1 lun 0: <RODIME, RO3000S, 2.40> SCSI1 0/direct fixed
sd8: 43MB, 680 cyl, 5 head, 26 sec, 512 bytes/sec x 88400 sectors
si1 at vmes0 addr 0xff204000 level 2 vector 0x41 : options=3
scsibus1 at si1
sd1 at scsibus1 targ 0 lun 0: <QUANTUM, LP80S  980809404, 3.3> SCSI2 0/direct fixed
sd1: 80MB, 921 cyl, 4 head, 44 sec, 512 bytes/sec x 164139 sectors
sd2 at scsibus1 targ 1 lun 0: <QUANTUM, LP80S  980809404, 3.3> SCSI2 0/direct fixed
sd2: 80MB, 921 cyl, 4 head, 44 sec, 512 bytes/sec x 164139 sectors
sd3 at scsibus1 targ 2 lun 0: <QUANTUM, LP80S  980809404, 3.3> SCSI2 0/direct fixed
sd3: 80MB, 921 cyl, 4 head, 44 sec, 512 bytes/sec x 164139 sectors
sd4 at scsibus1 targ 3 lun 0: <QUANTUM, LP80S  980809404, 3.3> SCSI2 0/direct fixed
sd4: 80MB, 921 cyl, 4 head, 44 sec, 512 bytes/sec x 164139 sectors
sd5 at scsibus1 targ 4 lun 0: <QUANTUM, LP80S  980809404, 3.3> SCSI2 0/direct fixed
sd5: 80MB, 921 cyl, 4 head, 44 sec, 512 bytes/sec x 164139 sectors
sd6 at scsibus1 targ 5 lun 0: <QUANTUM, LP80S  980809404, 3.3> SCSI2 0/direct fixed
sd6: 80MB, 921 cyl, 4 head, 44 sec, 512 bytes/sec x 164139 sectors
sd7 at scsibus1 targ 6 lun 0: <QUANTUM, LP80S  980809404, 3.3> SCSI2 0/direct fixed
sd7: 80MB, 921 cyl, 4 head, 44 sec, 512 bytes/sec x 164139 sectors

Everything works fine, though I get slightly disturbing messages

si_intr: spurious from SBC
isr_vectored: vector=0x41 (not claimed)

on boot (typically repeated about four or five - not seven - times),
though they don't recur and they appear to be harmless.  The
"vector=0x41" seems to imply they're related to the second si, but
aside from that I have no idea what's causing them.  When sd1-sd7 are
on, I normally merge them into a ccd, at which point they amount to a
usable-sized disk.  (80 megs is tiny; 7*80=560 megs is not quite so
tiny.)  I haven't really stressed the resulting ccd, though I have
exercised it a bit.  The pile of Quantum LP80Ss are some disks I picked
up cheap second hand; I got ten of them for CA$200, about the same
dollars per meg as a new 9-gig disk.  I mounted them between a couple
of pieces of sheet metal, found a power supply, and crimped some 50-pin
DIL header connectors onto a piece of ribbon cable.  Of course I can't
put more than seven of them per SCSI chain; wide SCSI they ain't.  (The
other three are sitting idle at present, not connected to anything.)

I also have an hp300 at home; its dmesg output reads as follows.
Comments in <angle brackets> have been edited in by me now as

NetBSD 1.2_BETA (GENERIC) #0: Fri Jan  3 02:23:18 EST 1997
HP9000/320 (16.67MHz MC68020 CPU, HP MMU, 16.67MHz MC68881 FPU, 16K virtual-address cache)
delay constant for this cpu: 123
real mem = 6283264
avail mem = 3264512
using 153 buffers containing 626688 bytes of memory
hil2: US ASCII keyboard
hil1: security code 10 4 b4 41 1a 52 13 f 41 0 0 0 0 0 0 0
dma0: 98620B, 2 channels, 16 bit
grf0 at addr 0x560000: 1024 x 768 monochrome topcat display (console)
ite0 at grf0: attached		<1024x768 ain't thrilling, but works>
hpib0 at scode7 ipl 3: Internal HP-IB
rd0 at hpib0 slave 0: 7937H	<Big hundred-pound rackmount beast>
rd0: 698 cylinders, 13 heads, 1116102 blocks, 512 bytes/block
ppi0 at hpib0 slave 5
dca0 at scode9 ipl 5 flags 0x1: no fifo		<serial>
hpib1 at scode14 ipl 6: 98625A or 98625B fast HP-IB
dca1 at scode17 ipl 6: no fifo			<serial>
unconfigured card id 42 at sc18			<see below>
unconfigured card id 42 at sc19			<see below>
le0 at scode21 ipl 5: address 08:00:09:00:65:cb	<ethernet>
le0: 8 receive buffers, 2 transmit buffers
Changing root device to rd0a

Jason Thorpe (whom I had the good fortune to meet when I was at the
IETF in San Jose last month) says this machine may have the dubious
honor of being the slowest machine NetBSD currently runs on.  I didn't
think to ask at the time whether NetBSD/vax ran on a VAX-11/725, which
(having used both) I'd say could give this box a crawl for its money.
The "unconfigured card"s are two more serial ports; dca1 is one third
of a three-port serial line card.  To date I haven't reconfigured and
rebuilt a kernel that knows about all three ports on that card.  I
suspect hpib1 may be flaky; when I put the disk on it, it hangs,
sometimes as early as in the bootblocks, sometimes as late as after
"Changing root device to rd0a".  I want to do X on this machine
someday, but the X I was able to find for the hp300 port did not
include a server (or at least so its README claimed) but I'm sure I saw
someone mention an X server for such a machine on the lists.  Someday
I'll get around to digging through the archives and pestering whoever
it was.  (Both the Sun-3s run X on their cg2 consoles, but we have only
two monitors, one of which is a bit flaky - anyone got a spare color
Sun-3 (or compatible) monitor to unload cheap?  Especially anyone in

I've also got a 386-based machine, about which I know little; it is
turned off.  Its disk currently has Linux on it, but I will probably
install NetBSD/i386 when I get around to bringing it back online.

We've got a lot of local software compiled on the machines at home,
somewhat less for the SPARC at work (it gets less use and mostly runs
SunOS 4.* binaries anyway).  At home, we have a lot of "private" local
software, stuff I wrote myself, but of packages people might recognize,
we have
	- X11R6.1p1 (a nontrivial build!)
	- btoa/atob 4.0
	- BIND 4.9.4
	- The IJG's JFIF (jpeg files) software
	- less version 177
	- MH, the mail user agent
	- netpbm, the image manipulation utilities
	- perl 5.003
	- PGP 2.6.3i
	- procmail 3.11pre3
	- sendmail 8.7.5 (yeah, but all local users are trusted)
	- ssh 1.2.14
	- TCP wrappers 7.2
	- VIM 3.0
This list is taken from one of the -3/260s.  The hp300 is running some
but not all of this; missing are X, BIND, the jpeg stuff, MH, netpbm,
perl, pgp, procmail, sendmail, tcp-wrappers, and VIM.

(In case you're curious, here are the names I have for the stuff I
wrote: adjtime, c-publish, charcode, count, fsm, halign, ideacrypt,
libidea, libmd5, libsearchstr, mcgrep, mcsh, md5, mimeutils, mtar, nc,
see, skipcat, splitmerge, wait-for, wraphfile; also CP, MV, find [a
complete rewrite], tar [a complete rewrite], xargs [a complete
rewrite], bps, buffer, catblock, cvtbase, findproc, pw, pwgen,

I'll be glad to correspond with anyone interested about any of the
above; anyone is also welcome to pick up any of what I've said above
for a who's-running-what collection, either hardware or software.

					der Mouse

		     7D C8 61 52 5D E7 2D 39  4E F1 31 3E E8 B3 27 4B