Subject: DEc 3rd sup; SPARC 1+ dies with all pmegs gone
To: None <current-users@NetBSD.ORG>
From: Rob Healey <rhealey@MR.Net>
List: current-users
Date: 12/03/1996 18:03:11

	Supped todays stuff hoping to get NFS changes and ran into a
	little problem, mainly the kernel wouldn't boot. Dies shortly
	into boot with:

Booting from: sd(0,0,0) 
>> NetBSD BOOT [$Revision: 1.4 $]
Booting netbsd @ 0x4000
[ preserving 142432 bytes of netbsd symbol table ]
Copyright (c) 1982, 1986, 1989, 1991, 1993
    The Regents of the University of California.  All rights reserved.
NetBSD 1.2B (HUGH) #0: Tue Dec  3 15:44:25 CST 1996
real mem = 37699584
panic: me_alloc: all pmegs gone

	Rebuilt everything last week from the 11/25/96 sup. Today I ran make
	includes to catch recent .h changes and then config'd and
	make depend then make the kernel, config dir was from scratch so
	no remnants would be around. Tried to boot it and KA-BOOM,
	the above. Stack trace showed:

db> t
_me_alloc(0, f811864c, fa, 22, 2, f8c2a000) at _me_alloc+0x78
_pmap_enk4_4c(f811864c, fa887000, 22, f81203f8, f8159950, e00003e1) at _pmap_en
_pmap_enter4_4c(f811864c, fa887000, 3e1000, 7, 1, f8103d5c) at _pmap_enter4_4c+
_vm_fault(ffdf, fa887000, 7, 1, f8628004, f8118438) at _vm_fault+0xc78
_vm_fault_wire(0, fa887000, fa888000, fa888000, f8639e40, 1) at _vm_fault_wire+
_vm_map_pageable(f862af00, fa887000, fa888000, 0, ffffffff, 1cc) at _vm_map_pag
_cpu_startup(f811d400, f8105800, 1, 1, ffffffff, 10) at _cpu_startup+0x190
_main(0, 7, 1, f81040cf, 64657669, 636f6d70) at _main+0x54
startmap_done(0, 103ffb, 10000000, 0, 81, ffd0a000) at startmap_done+0x108

	Hardware is a crusty old 1+ SPARC with 36M of memory and 1 drive.

	Any ideas what might be wrong? Did the param.h changes goof something
	up? Any other major changes in the past week that would blow an old
	crusty sun4c out of the water in the pmegs dept.?