Subject: Re: unionfs
To: Phil Knaack <>
From: Bert Driehuis <>
List: current-users
Date: 11/20/1996 00:57:47
>	Someone mentioned that the problems with unionfs have to do with
>two simultaneous processes accessing a union-mounted area, although I've
>been using union-mounted source directories to rebuild the world for many
>moons and versions of netbsd, and have never seen a problem.
>	Of course, on every machine I use unionfs on, I happen to be the
>only user who has an account. =-)

Hmmm, just today, I unpacked the 1.2 source tree (on my freshly upgraded
Sparc running the GENERIC 1.2 kernel) onto /usr/src, which is a null mount
over /home/_src, and while tar was chugging away creating stuff, I was
browsing /home/_src/sys/net (which by that time, tar was long done with).
When I tried file name completion on /home/_src/sys/net, both my shell and
tar hung in a deadlock (sorry, didn't write down the WCHAN, I was
programming in another window at the time and was thus mentally elsewhere).

So, at least nullfs in 1.2 still has a deadlock potential. I sometimes also
see console messages "null_node_find: vget failed". Those appear without

I haven't tried unionfs in 1.2 yet; I know that people have been fixing
some things, so it might be an idea to use unionfs instead. Haven't tried

				-- Bert

Bert Driehuis                 God, grant me the serenity to accept the things        I can't change, courage to change the things I
                              can, and the wisdom to know the difference.