To: Gordon W. Ross <>
From: Leo Weppelman <>
List: current-users
Date: 11/15/1996 23:15:32
Gordon W. Ross wrote:

[ Allen's idea to reverse the MACHINE_NONCONTIG define ]
> > 
> > -allen
> Yes, replacing this "option" with one of the opposite sense
> would help discourage proliferation of the old pmap interface
> by making it a little more difficult.  (The port master would
> have to consciously add MACHINE_CONTIG 8^)  Maybe the opposite
> sense name could be better -- how about PMAP_MEM_CONTIG instead?

Looks like a better name to me.

> So, I propose that we:
> (1) Add the PMAP_MEM_CONTIG definition to all ports that do not
>     presently use the MACHINE_NONCONTIG option.
> (2) Change the VM code conditionals from
> to
> 	#ifdef PMAP_MEM_CONTIG	/* old, depreciated way */
> (3) Remove the MACHINE_NONCONTIG definition from the
>     ports that use the preferred interface.
> The intention would be to make it more convenient to use the
> preferred interface than to use the depreciated interface.

Good idea. Maybe the ports currently using MACHINE_NONCONTIG should
cleanup their pmap.c to get rid of the conditional too (If they
haven't done already - I haven't ;-)