Subject: Re: Problems with kerberos.
To: Christopher J Mason <>
From: Bill Studenmund <>
List: current-users
Date: 11/09/1996 14:12:50
> I've just ftped src/domestic and compiled and installed.  It compiled
> without error, but whenever I try to run most of the kerberos binaries I
> get:
> cmason@ros:/etc/kerberosIV# klist
> /usr/libexec/ Undefined symbol "_crypt" in klist:/usr/lib/
> I even tried sticking -lcrypt to the CFLAGS variable in
> src/domestic/lib/libkrb/Makefile.  Same result.

You need to add -lcrypt to the linking programs, not to the library.

I have a "LDFLAG+= -lcrypt" line in my make file for kinit, but not
for klist. I don't understand why you're getting this error.

> Also, when trying to kinit I get:
> cmason@ros:/etc/kerberosIV# kinit
> NetBSD Kerberos (ros)
> Kerberos Initialization
> Kerberos name: cjm
> kinit: Can't send request (send_to_kdc)
> I'm pretty sure I have the things setup correctly in /etc/kerberosIV/. 
> I just grabbed the krb.conf and krb.realms from a machine with working
> kerberos.  Is there some different configuration thing that I have to do
> that is different for NetBSD?  Is there anyone on the list from CMU
> which has gotten NetBSD kerberos to work with andrew?  Anything special
> that I have to do?

I thought my send-pr was all that was needed to get kerberos up with
andrew (we're using it here too).

It might be time to move this thread to current-users as this code
is all M.I.

Take care,