Subject: Re: elk-3.0 on NetBSD-current?
To: Jon Buller <>
From: Wiker, Raymond <>
List: current-users
Date: 09/11/1996 09:00:11
Jon Buller writes:
 > I wrote (so I am replying to my own message...):
 > > I'll recompile without the -O2 flag given to gcc and see what happens.
 > Well, that fixed it.  It all seems to work now, except it`s a bit
 > slower than it should be.  Dump works, but running the new executable
 > it creates doesn't.  (Should that have a smiley or a frowny?  Both
 > I guess...) I suppose I need to do a little more fiddling with the
 > parameters for dump in the elk config file.  I also suppose that
 > that is machine dependent, so I should ask if anyone has a hint on
 > port-pc532.  Correct?  Perry, could you send me your config file
 > for use as a starting point?  I syspect that the 386 and 532 code
 > is similar, since they are both little-endian machines with similar
 > MMUs (and the same OS).

	I tried compiling elk 3.0 last night again, and got the same
problem that you reported. I have to hit my head against a wall a few
times before I'll remember exactly what the problem was - I haven't
looked at this for about a year, but there was one specific lisp
primitive that was compiled incorrectly. I think I even posted about
it to the pc532 or netbsd-current lists...

	I do have a config file - derived from the i386-bsdi-gcc one.