Subject: Not enough memory?
To: Current Users <current-users@NetBSD.ORG>
From: Jukka Marin <>
List: current-users
Date: 08/20/1996 11:36:03

It's me again. ;)

I got the Applixware demo CD and I'm trying to run it on SS1+ / NetBSD.
Installing the software was annoying because the filenames were all in
upper case, but the installation script was trying to use lower case
names.  I may still have parts of my stunos emulation missing as well.

The Problem (which I think is not a Sparc-specific one):

When I run the applix binary, it complains "Not enough memory".  I have
16 megs physical and 96 MB swap (87 MB free).  I tried to 'unlimit' but
it didn't help.  Here:

jmarin@pyy ~ %(238)/home/jmarin/app/applix
/home/jmarin/app/axdata/axmain: Not enough memory
jmarin@pyy ~ %(239)ll /home/jmarin/app/axdata/axmain
-rwxr-xr-x  1 jmarin  user  13885440 Apr  1 21:04 /home/jmarin/app/axdata/axmain
jmarin@pyy ~ %(240)limit
cputime         unlimited
filesize        unlimited
datasize        65536 kbytes
stacksize       65536 kbytes
coredumpsize    unlimited
memoryuse       13936 kbytes
descriptors     1772
memorylocked    13936 kbytes
maxproc         532

Could it be that the 'memoryuse' limit keeps axmain from running?  If so,
is there a way to raise this limit (other than buying more physical RAM)?
I'd like to get this demo running soon (before it expires).

Any help appreciated,



                     ---> <---