Subject: Re: No timeouts? NFS problem...
To: Todd Vierling <>
From: Phil Knaack <>
List: current-users
Date: 08/13/1996 20:00:49
Todd Vierling <> writes:

>NFS server blah not responding still trying

>This is a common message on many BSD-based machines when a hard mounted nfs
>partition is accessed and the server is down for 2-3 minutes or more.  I
>don't know if NetBSD's nfs is the same way, but I'd hazard a guess that it

>Read mount_nfs(8) and pay close attention to the '-s' (aka '-o soft') 
>option.  The default timeout ('-x nn', aka '-o retry=nn') is probably too
>short for what you want, but that's the option you need. 

	I have tried using some of these options, to no avail. At the moment
I have a partition mounted using the following command:

		% mount_nfs -R 1 -x 1 -s -i -b -T rachel:/ /nfs/rachel

	I killed off nfsd on rachel following this command, and then did

		% file /nfs/rachel/netbsd 

	Which has not yet proceded to fail, produce any console message, or
anything, and it has been seven minutes thus far. I have tried several
combinations with the "-s", "-R", and "-x" flags, and nothing works.

	[Mark that, the machine finally said 
		nfs server rachel:/: not responding
	just now]

	Also, the manpage states that "-b" is useful in the fstab if you want
a filesystem mounted but which are not important to multiuser operation. It
is my understanding that it will begin trying the mount, and after a certain
amount of time it will fail, fork off a child to continue trying, and then 
itself exit. I even see code to this effect in mount_nfs.c.

	But that isn't what in fact happens .. it just hangs forever.

	Am I doing something wrong?

	I do find the "-i" flag _very_ useful however.

Phillip F Knaack
Database Programmer, Information Development for Extension Audiences (IDEA)
Iowa State University Extension