Subject: More on named and alias IP problems
To: None <current-users@NetBSD.ORG>
From: Raphael Jaffey <>
List: current-users
Date: 06/21/1996 13:26:48
This is a follow up to my original post with the subject: "Can named listen
to alias IP addresses?"

I added the alias as follows "ifconfig ed2 inet <address> alias", then I
stopped and restarted named.  The alias address works just fine for telnet
and other TCP services I've tried, but when I try nslookup from another
UNIX host it doesn't work.  When I looked at netstat's output I saw that
named was only listening on 2 ports, localhost and the real IP address of
the interface, but not on the alias.  So I assumed this was the problem,
hence my original post.  I've received some responses indicating that this
configuration should work so I did some more investigation and here's what
I found:

When I run "nslookup - <alias address>" on other UNIX hosts (both HP-UX and
AIX) they give up and use their default nameserver after about 15 seconds.
When I configure a Macintosh or PC to use the <alias address> for its
nameserver it works just fine, so I used a sniffer on the network and found
out what's going on:  The query's destination is the <alias address>, but
the reply's source is the <real address>.  The Mac and PC don't seem to
care that the source of the reply is different from the destination of the
original query.  The UNIX hosts on the other hand don't like this at all.
In fact they reply with ICMP "destination unreachable, port unreachable"
messages.  Any ideas on how to make this work?

By the way some of your responses made reference to BIND 4.9.3 which I'm
not running here.  I'm using what comes with NetBSD v1.1 which appears to
be 4.8.3.  Dunno if this makes a difference.

Thanks to all folks who replied to my original post and thanks in advance
to any who reply to this one!


Raphael Jaffey