Subject: Re: config just reports errors
To: Julian Bean <>
From: Michael L. VanLoon -- <>
List: current-users
Date: 04/02/1996 23:02:36
>>I have the version 1.1 distribution of everything except the kernel, which
>>I use either GERERIC#5 or ADBTEST.132 on a serial console as I'm using a
>>Classic II.  I downloaded the source for sys (sys.tar.gz) from
>> on the 26/3/96 and the ABDTEST.132 patch kit.  However,
>>every time config sees a '|' in the sys/conf/files files, it gives a syntax
>>error.  I noticed that there was a files.oldcfig (or something like that)
>>that used an "optional" syntax, so tried that as my files file, but I still
>>got syntax errors.  I removed all the '|' options and got a different set
>>of syntax errors.  As far as I know, I followed all the instructions on
>>both the ABDTEST patch and build a hernel how-tos.  Is there a problem with
>>versions here?

>I have noticed exactly the same thing - config doesn't like the new logical
>or syntax (it is new, isn't it?).  I thought it must be that my config
>binary was out of sync, so I re-compiled that, but no joy.

Did you rebuild config?  That is the first thing you should try if
you're getting kernel config problems (that you know aren't your own
fault :-).

In this case that would be especially applicable, since I've seen
several commit messages fly by that specifically mention updates to
config syntax.

  Michael L. VanLoon                       
       --<  Free your mind and your machine -- NetBSD free un*x  >--
     NetBSD working ports: 386+PC, Mac 68k, Amiga, HP300, Sun3, Sun4,
                           DEC PMAX (MIPS), DEC Alpha, PC532
     NetBSD ports in progress: VAX, Atari 68k, others...