Subject: Problem with NetBSD nfs server or SunOS client ?
To: None <current-users@NetBSD.ORG>
From: Valtteri Vuorikoski <>
List: current-users
Date: 03/30/1996 16:40:47
 There appears to be a problem with either the NetBSD nfs server or the 
SunOS 4.1.3_u1 nfs client relating to unix domain sockets. The effect is 
that on the SunOS machine, syslog() doesn't work because it tries to use 
a unix domain socket in an nfs mounted directory. This is what happens 
when it tries to use /dev/log (trace from logger, though the same happens 
with my test program):

sendto (1, "<13>Mar 30 16:31:28 vuori: foo\n", 31, 0, 0x68d0, 16) = -1 
ENOTSOCK (Socket operation on non-socket)

 However, if I put a socket into /tmp (an mfs filesystem) and try to use 
it (trace from my test program):

sendto (3, "<13>Mar 30 15:38:18 vuori: foo\n", 31, 0, 0xeffff8b0, 11) = 31

 The first parameter (socket) is valid in both cases.

 The SunOS machine is a diskless SparcClassic. I have tried multiple 
SunOS libcs and kernels (all more or less 4.1.3_u1 though) to no effect. 
My current NetBSD kernel is from around Mar 20, but this isn't a new 
problem, it happened before the move to the new nfs code too (syslog on 
the SunOS box has never worked (except for kernel logs, but those don't use 
a unix domain socket)).

 'file' recognizes the log socket as a 'socket' on both the NetBSD 
server and SunOS client.

 The NetBSD is NetBSD/mac68k, but this should pretty MI.

'Good-bye and hello, as always'