Subject: Re: amd: yp_order not supported by NIS+ servers
To: None <>
From: Luke Mewburn <>
List: current-users
Date: 03/27/1996 11:10:12
Matthieu Herrb writes:
> I've encountered a new problem with amd. I run a NetBSD/sparc machine
> on a network where we are using NIS+ (with NIS compatible mode). amd
> cannot work in this environment because it uses yp_order() which is not
> supported by NIS+ servers in NIS compatibility mode.
> From the Solaris 2 ypclnt(3N) manpage:
>          yp_order() returns the order number for  a  map.   This
>           function  is not supported if the ypbind process on the
>           client's system is bound to an NIS+ server  running  in
>           "YP-compatibility mode".
> While I admit that it's a Sun bug (and Sun admits it too, it's bug Id
> 1142666), has anyone found a workaround to this problem ?

Yep. If the NIS+ server is Solaris 2.x, and you're just using it in
NIS compatibility mode, I suggest that you ditch NIS+ and install
NSKit 1.2 (now free from sun, as a patch or something like that.)

I gave up on NIS+_in_NIS_compat_mode a long time ago.