Subject: possible problems with latest ppp (what else!?)
To: 'current-users@NetBSD.ORG' <current-users@NetBSD.ORG>
From: Davyd Norris <>
List: current-users
Date: 03/08/1996 11:59:02
Hi folks,

I have been running a -current kernel from just after the disk_unbusy =
panic days (about Jan 11) and since then, my users have been reporting =
masses of frame errors in their ppp connections and their file transfers =
are hanging after about 50k or so.

I have tried a few different things without success, and built a new =
kernel yesterday (Mar 7) to no avail.  On my end, pppstats as well as =
netstat report no errors, but all users see heaps of frame errors =
reported by Trumpet Winsock.  There is in fact a bug in Trumpet 2.1 that =
causes problems with PAP and modem hangups unless you turn on PPP =
tracing (makes it hard to find when turning on debugging makes the =
problem go away! :) )

We are running identical modems (Multimodem 288ZDX at 115200 on the BSD =
box and 57600 at their end - some users are on Win95 and can get the =
speed supposedly, I let their end decide.  Eventually I want to hook my =
BSD machine up as well) at either end, and the ppp daemons from Mar-7 =
-current using PAP.

Has anyone seen this behaviour from PPP recently, or is it just me and I =
have to look further afield?  I have no silo overflows reported to speak =
of - I got my first the other day as someone tried to get the JDK (4 =
Megs - big file for them) but only one report and it shut up again.

Any ideas appreciated,


PS. One other thing that just struck me - I installed a second com card =
which I later found out uses shared IRQ's and is not working or =
applicable to the machine.  Could this be interfering in some way with =
the first set of com ports?  I put this in around Christmas time when =
everyone was away, so they wouldn't have reported much then anyway.