Subject: tmp in mfs and swap
To: None <current-users@NetBSD.ORG>
From: Jesus M. Gonzalez <>
List: current-users
Date: 01/30/1996 11:19:24
	I've moved to use /tmp in memory file system (BTW, I've
seen a great performance gain, specially when compiling).
But now I'd like to use the previous /tmp partition as a swap
partition. I've tried, after the fstab(5) manpage,
to use "none" as the mount point, but mount -a doesn't seem to
recoginize it on bootstrap (non existent mount point, or something
like that). Should I do something more to "prepare" the partition?
Is the man page wrong?

	On the other hand, swapon manpage talks a bout "sw" in 
/etc/fstab. I've also tried that, and it also doesn't work.
None of the many combinations I've tried for fstab allows "swapon -a"
to use /dev/wd0e for swapping.

	My current fstab is the following:

/dev/wd0a / ffs rw 1 1
/dev/wd0e none swap rw 0 0
swap /tmp mfs rw 0 0
/dev/wd0f /var ffs rw 1 2
/dev/wd0g /usr ffs rw 1 3

	All this in NetBSD-1.1/i386. Thanks in advance,


PS: BTW, I'm using "pstat -s" to know if swapon mounted the
new partition. I assume a new line should appear there about
partition  /dev/wd0e... Is that right?

Jesus M. Gonzalez Barahona         | addr.:  c/ Butarque, 15
Grupo de Sistemas y Comunicaciones |         28911 Leganes, Spain
Departamento de Informatica        | tel: +34 1 624 94 58
Universidad Carlos III de Madrid   | fax: +34 1 624 94 30
e-mail:       | www: