Subject: Re: autoconf and m4
To: Carsten Hammer <>
From: Jason Thorpe <>
List: current-users
Date: 11/23/1995 08:00:17
On Thu, 23 Nov 1995 12:59:54 +0000 (GMT) 
 Carsten Hammer <> wrote:

 > I would like to know if there is any way to make autoconf (the gnu thing)
 > work with netbsd-current especially with the netbsd m4. 
 > Autoconf says it needs m4 version 1.1 (or was it 1.3, in any case
 > something that gives something back when doing m4 --version).
 > I did not try yet to make it work with NetBSD m4 but the README 
 > of autoconf says it maybe makes problems with BSDish m4's.
 > Is there a good reason to not change to GNU m4(Other than religious ones?)?

Switching to GNU m4 would add to the GPL'd code in the tree.  I usually 
just install GNU m4 in /usr/local/bin as `gm4', and let whatver wants to 
use it use it.  (Most programs that require GNU m4, including autoconf, 
will look for `gm4' in case you have both...)

Jason R. Thorpe                             
NASA Ames Research Center                               Home: 408.866.1912
NAS: M/S 258-6                                          Work: 415.604.0935
Moffett Field, CA 94035                                Pager: 415.428.6939