Subject: Re: NCR driver ** AGAIN **
To: None <current-users@NetBSD.ORG>
From: Dave Huang <>
List: current-users
Date: 11/14/1995 15:31:58
On Tue, 14 Nov 1995, Charlie Root wrote:
> For those of you not following the story - every so often (randomly
> - no heavy loading or stuff) the box goes apeshit and spits with an
> NCR driver assert error.  This neccesitates a cold boot - warm boots
> hang when the boot sequence gets to the second number in the 
> 8768765+874543874+9874654... sequence at boot. (Can someone tell me
> what these numbers are?  Is the second one swap? Am I stupid?)
> The system is:
> Pentium PCI 90 MHz 32Meg RAM
> NCR PCI Fast SCSI-II Controller
> Quantum Capella VP32210 2.1Gb Fast SCSI-II Hard Drive
> 2 SMC PCI Ethernet cards
> Diamond Stealth SE PCI Graphics card
> 2 x COM
> 1 x LPT
> NB: This type of HDD is being used by at least one other person
> without problem. (Someone out there mentioned it in the last week or
> so)

I guess that would be me... :) I still haven't had the assertion failure 
ever since I upgraded to NetBSD-current, but about two days ago, when 
booting, I got this message:

sd0(ncr0:0:0): non-media hardware failure, data = 6d 00 0f bf eb 83 fd ff
74 14 80 0e 02 8b ac 24 ac 01 ... etc (it was about 6 lines of hex dump,
and I didn't feel like writing it all down :) Is there any way to get
these kernel messages sent to a serial port, btw?) It repeated that
message about 6 or 7 times before the system panicked (unable to mount 
root, I believe).

I'm not sure exactly what happened before I got the error messages, since
everything scrolled off the screen, but I know it got to the "ncr0:
restart (scsi reset).", and I think it also got to "scsibus0 at ncr0". 
And I think I saw "probe0" or something at the beginning of the first 
"non-media hardware failure" line.

Doing a warm reset didn't cure the problem; I had to hit the reset 

Also, I've occasionally had the system hang after printing "biomask 4860 
netmask 0 ttymask 1a" (right before "changing root device to sd0a").

I'm running a 1.1_ALPHA kernel from November 8 on a:

Pentium 100, 16MB
Asus SC200 SCSI controller (NCR 53c810 based)
Quantum Capella VP32210 Fast SCSI-II HD
Toshiba XM-5301TA (? My manual says XM-5301B) SCSI-II CDROM
Ancient Conner CP3204F IDE HD
Matrox Millenium graphics card
3Com Fast Etherlink 10/100 (3c595)
Sound Blaster 16
And the normal stuff... 3.5 and 5.25 floppies, 2 serial, 1 parallel 
port... whatever else comes with the motherboard :) (Asus P/I-P55TP4XE)

Oh yeah, I do have MAXBSIZE set to MAXPHYS in my kernel (I thought that 
didn't work?)
Name: Dave Huang     |   Mammal, mammal / their names are called /
INet:   |   they raise a paw / the bat, the cat /
FurryMUCK: Dahan     |   dolphin and dog / koala bear and hog -- TMBG
Dahan: Hani G Y+C 19 Y++ L+++ W- C++ T++ A+ E+ S++ V++ F- Q+++ P+ B+ PA+ PL++