Subject: Re: Weirdness after a disk death
To: Valtteri Vuorikoski <>
From: Erik Vogan <>
List: current-users
Date: 10/09/1995 15:58:33
On Mon, 9 Oct 1995, Valtteri Vuorikoski wrote:

>  On friday, my 0827 -current kernel died with a panic: bad dir, and
> I let it do sync, which failed (syncing disks... 1 1 1 1 1 1 1 [etc]),
> after which it said that it was doing a kernel dump, and then rebooted.
> Afterwards, the superblock on the root partition was gone, and after I


>  - both login and su don't prompt for password. After entering a username
> for an account with a password at the login:-prompt, it just says 'Login
> incorrect' without a password-prompt. su just says 'Sorry'. I've replaced 
> my libs, my login binary, my su binary, my getty, my init, my gettytab 
> and rebuilt the password dbs and tried a few kernels, but to no avail, 
> the same thing still happens. I'm on console, neither getpwuid() nor
> getpass() had any problems in test programs. The terminal type is set
> to vt220.

	At some point in the past (in the midst of a rather long and 
rambling crash report, I think) I posted the solution to this.  It worked 
on my machine, after I'd taken most of the step you describe.  No 
gaurantees for yours!!

	My problem seemed to involve some of the /dev files not having 
the correct owner/group and or other intringuing problems (perhaps at a 
very low level).  My solution was to remove EVERYTHING in /dev, and then 
rebuild devices from scratch (using either the install tool or MAKEDEV).  
Removing just the console and tty devices MIGHT work; I can't tell you 
cause I never bothered to try.

	Hope this works for you.  I can't help any with the other 
problems; they don't sound familiar.  Best of luck.

							erik vogan

~ Of all the races in all of the Galaxy who could have come and said a big
hello to the planet Earth, he thought, didn't it just have to be the Vogons.
							- HHGttG