Subject: XFree86 and memory mapping
To: None <port-i386@NetBSD.ORG, current-users@NetBSD.ORG>
From: None <>
List: current-users
Date: 08/31/1995 06:17:35
I'm having a hard time getting XFree86 to use linear memory access
with my Diamond Stealth 64 (2M) DRAM PCI board and NetBSD-current.

486DX4-100 ASUS VL/PCI/ISA motherboard, 24 MB RAM
Diamond Stealth 64 DRAM PCI (2 MB), Trio 64 chipset

Early August NetBSD-current, XF86 3.1.2 built from source.

The problem:
No matter what I do, I can't get the X-server to use linear memory
access.  It's clear to me that this isn't a problem with the aperture
driver, since I get the same error whether I use the aperture driver
or a kernel compiled with "options INSECURE"

The error messages from the server look like this:
Local bus LAW is 0xF3000000 but linear fb not usable
Can't use local bus framebuffer - linear access disabled
(not perfectly sure about the 0xF3000000, doing this from memory)

I have tried turning off all caching in the BIOS - it doesn't seem to
be a cache problem.

The reason I'm posting this to the NetBSD groups is that I noticed the
same problem with my previous video board (before it fried), which was
a VL-bus version of the same card.  The problem started at around the
time I upgraded from NetBSD-1.0 to -current.

I'd appreciate hearing from anyone who has an idea of how to get this


Todd Williamson