Subject: Stuff not working after update to current
To: None <current-users@NetBSD.ORG>
From: alphaepsilon <aellwood@MIT.EDU>
List: current-users
Date: 07/20/1995 09:14:48
Hi, the following things seem not to work on my system after updating
to current.  There are enough of them I haven't gotten around to
looking at any of them very hard.  Please don't think of this as a
flame (yeah go ahead jhawk ;-) I'm just it too much pain (CTS) to try
much more in the way of debugging.

I've updated to current as of July 14 from current as of May 15.

* My NCR SCSI card reports an occasional one of the following errors
every time I do a major file operation:
Jul 19 19:01:33 tetrahydrocannabinol /netbsd: ncr0: timeout ccb=f86fc800 (skip)

* mrouted reports the following errors every time I run ftp or another
network heavy operation (someone else had this, right?):
Jul 18 09:22:35 tetrahydrocannabinol mrouted[115]: warning - age_table_entry: 
SIOCGETSGCNT failing for ( Device not configured

* "Shutdown -r now" results in the machine hanging (though it does
still ping).  "reboot" works just fine.  Although I am running afs
clients, they print out their normal shutdown messages before it

* The XFree86 aperture driver doesn't work at all under this current.
When I run X trying to use it, my monitor doesn't mode switch and I
get black and white boxes all over the screen on top of eachother.

* XFree86 with the kernel in insecure mode has two problems:
  1) It's miserably slow.  I can barely do anything, and it's a Mach 64
     with 2 MB of DRAM and a P90.  An emacs takes almost 2 minutes to 
     load and ps augxww takes a minute.  Previously, X had slowed down 
     steadily until I restarted it.  Now it's continuously slow.
  2) My colormap is completely messed up.  "wheat" is a lavender like 
     color.  "green" is white.  But black, white, blue and red are okay.  
     If I look at images with xv, they come out partially garbled....
     like a section of the colormap is messed, but not the whole thing.  
     I'm running in 8 bit.  I can't run in 16/32 bit to see if that works 
     because the Mach 64 driver doesn't support DRAM at higher bit depths.
This was with a completely new binary distribution of X, but with my old
XF86Config, xinitrc and system.twmrc... (see below).

This is more of a suggestion than a bug:
* When I built my new kernel I neglected to build a new fsck with it
before rebooting.  Now I understand that given that, I deserved to
lose, but there should be a bigger warning about it.  I lost a most of /dev and a large portion of my X binary tree.  On
boot it tried to fsck and announced that my root partition was too
damaged and dumped me into a prompt.  I ran fsck, and it determined
that those files were damaged and should be removed.

Well, anyone is welcome to give me advice on what to do to debug any of
these.  I'm completely frustrated.  

Alexandra Ellwood             finger for PGP public key
<>        "Did you know there's pornography on the internet?"